Personal tools

Raspberry Pi

From HaskellWiki

(Difference between revisions)
Jump to: navigation, search
Line 14: Line 14:
   
 
* [http://www.mail-archive.com/haskell-cafe@haskell.org/msg99529.html Re: <nowiki>[Haskell-cafe]</nowiki> Haskell (GHC 7) on ARM]
 
* [http://www.mail-archive.com/haskell-cafe@haskell.org/msg99529.html Re: <nowiki>[Haskell-cafe]</nowiki> Haskell (GHC 7) on ARM]
  +
  +
* [http://www.raspberrypi.org/phpBB3/viewtopic.php?f=34&t=6655 Haskell/GHC observations on the official Raspberry Pi forum]
   
 
== GHC Status ==
 
== GHC Status ==
Line 24: Line 26:
   
 
'''Note:''' GHCi does not currently work on ARM below version 7.4.2. See [http://www.haskell.org/pipermail/haskell-cafe/2012-June/101704.html this post on haskell-cafe for information on this]
 
'''Note:''' GHCi does not currently work on ARM below version 7.4.2. See [http://www.haskell.org/pipermail/haskell-cafe/2012-June/101704.html this post on haskell-cafe for information on this]
  +
  +
[http://www.raspberrypi.org/phpBB3/viewtopic.php?f=34&t=6655 djhuk has been able to compile] and install GHC-7.4.2 via QEMU to the Raspberry Pi but there still seems to be some work to do.
   
 
== Current Issues ==
 
== Current Issues ==

Revision as of 16:50, 1 July 2012

This article is a stub. You can help by expanding it.

Contents

1 Introduction

Raspberry Pi is an ARM based single-board computer, developed for educational purposes, costing USD 25. For more details, see the Wikipedia article about Raspberry Pi, or the FAQ list.

Raspberry Pi Beta Board.jpg

2 Links

3 GHC Status

Of the "official" images currently available from the Raspberry Pi Downloads page, the following versions of GHC are available

Note: GHCi does not currently work on ARM below version 7.4.2. See this post on haskell-cafe for information on this

djhuk has been able to compile and install GHC-7.4.2 via QEMU to the Raspberry Pi but there still seems to be some work to do.

4 Current Issues

The main issues encountered so far is the memory limitations of the device, at 256mb GHC will execute fine, but problems will start to arise when using cabal to install new libraries, especially ones with lots of dependencies.

Potential solutions to this problem have been suggested, including using QEMU on a more powerful system and thus compiling your application there and copying the resulting binary across to your Raspberry Pi


5 See also