Personal tools

Talk:Phooey

From HaskellWiki

(Difference between revisions)
Jump to: navigation, search
 
Line 1: Line 1:
  +
   
 
This is very interesting. Getting this apparently simple proof of concept working is difficult for me. I've tried on Suse 10.2 and Windows XP.
 
This is very interesting. Getting this apparently simple proof of concept working is difficult for me. I've tried on Suse 10.2 and Windows XP.
Line 4: Line 5:
   
 
wxMSW-2.4.2-setup.zip
 
wxMSW-2.4.2-setup.zip
  +
 
ghc-6-4-bld2.msi
 
ghc-6-4-bld2.msi
  +
 
wxhaskell-bin-msw2.4.2-ghc6.4-0.9.4-1.zip
 
wxhaskell-bin-msw2.4.2-ghc6.4-0.9.4-1.zip
  +
   
 
The recommended wxwindows 2.4.2 requires a wxhaskell dependent on ghc640. The problem is that arrows require base >=2.0
 
The recommended wxwindows 2.4.2 requires a wxhaskell dependent on ghc640. The problem is that arrows require base >=2.0

Revision as of 23:25, 20 February 2007


This is very interesting. Getting this apparently simple proof of concept working is difficult for me. I've tried on Suse 10.2 and Windows XP. files I used on XP:

wxMSW-2.4.2-setup.zip

ghc-6-4-bld2.msi

wxhaskell-bin-msw2.4.2-ghc6.4-0.9.4-1.zip


The recommended wxwindows 2.4.2 requires a wxhaskell dependent on ghc640. The problem is that arrows require base >=2.0 I could update Cabal to 1.1.7 using darcs etc. But I find no instructions on how to update the base-1.0 which comes with GHC 6.4.0. Even with instructions I think it requires a C compiler or more?