Personal tools

Talk:The Other Prelude

From HaskellWiki

(Difference between revisions)
Jump to: navigation, search
(fmt, Prelude', and boolean)
m (fmt)
Line 28: Line 28:
 
:: If we really want to go for consistency, then perhaps 'joinMap'? --[[User:Nmessenger|Nmessenger]] 00:05, 4 January 2007 (UTC)
 
:: If we really want to go for consistency, then perhaps 'joinMap'? --[[User:Nmessenger|Nmessenger]] 00:05, 4 January 2007 (UTC)
   
::: <hask>joinMap</hask> is consistent in that is says what it does :) <hask>flatMap</hask> would have introduced it (<hask>join . map</hask>) as a bit more sophisticated ''concept'' (highlighting the map underneath the monadic container). Doesn't really matter. Thanks for pulling <hask>(>>)</hask> up. I am not aware of any caveats, though the experts may jump in and say "you see, this and that are the reasons we didn't do it ..." and ruin the day ;)
+
::: <hask>joinMap</hask> is consistent in that is says what it does :) <hask>flatMap</hask> would have introduced it (<hask>join . map</hask>) as a bit more sophisticated ''concept'' (highlighting the map underneath the monadic container). Doesn't really matter. Thanks for pulling <hask>(>>)</hask> up. I am not aware of any caveats, though the experts may jump in and say "you see, this and that are the reasons we didn't do it ..." and ruin the day ;) --[[User:Uchchwhash|Pirated Dreams]] 11:02, 4 January 2007 (UTC)
--[[User:Uchchwhash|Pirated Dreams]] 11:02, 4 January 2007 (UTC)
 
   
 
== Duplicate definitions ==
 
== Duplicate definitions ==

Revision as of 18:29, 4 February 2007

i have no idea what i'm talking about here, but shouldn't "Monad m" imply "Functor m" if we're already starting with a clean slate? Also, what should the solution to "head", etc be? --Johannes Ahlmann 09:47, 21 December 2006 (UTC)

"Monad m" should imply "Functor m". By your question about "head", do you mean the problem of it being undefined on
[]
? BrettGiles 14:13, 21 December 2006 (UTC)
head
,
fst
et cetera are projection functions. They can, in fact, be achieved by pattern matching, and are done that way often. It seems to me that at least the Prelude should be very mathematical and leave them out. YMMV. But
Monad m
should really imply
Functor m
if we want to be mathematical, and indeed we do. --Pirated Dreams 22:33, 21 December 2006 (UTC)
I'm not so sure whether you can just leave projections out of the prelude and it definitely wouldn't solve the underlying problem. Also I'd love to see some functions from MissingH (especially a sensible "split") in the prelude. Furthermore there's the question which functions from other libraries should be exported by Prelude (either, list functions, error/catch, fail, fmap, IO functions, mapM, maybe, read/reads, sequence, Numeric functions, ...). There definitely has to be some discussion about the necessity of including some of these. --Johannes Ahlmann 12:34, 23 December 2006 (UTC)

1 Naming

Although the name of the page "The Other Prelude" does not seem to fit the Wiki standard (sentence case says: The other prelude), I left it as it appears to be a proper name when you read the content. BrettGiles 14:13, 21 December 2006 (UTC)

Yes Brett, at least that was my intention. --Pirated Dreams 22:33, 21 December 2006 (UTC)
I propose the a rename to
Prelude'
for the module. Short, and parallels Haskell'. Also, I'm not fond of the name
boolean
. If there are no objections, I'll rename it to
if'
--Nick Messenger 18:28, 4 February 2007 (UTC)

2 Issues

I propose the following:

  • The Functor hierarchy proposal should be adopted.
  • There will be basic algebra modules in the Prelude hierarchy. Named, possibly,
    TheOtherPrelude.Algebra
    , if the numerical prelude people are happy with it. At this point I think the name, though clear, is very long.
  • I propose operators to be preferred over alphanumeric names.
    (++)
    seems way cooler than
    M.plus
    . YMMV. Vote here. About the precedence issue, I think proper usage of parentheses is enough for all practical purposes. Besides, (++) is associative.
  • join
    is the same as more specific
    concat
    as far as I get it. The task it accomplishes is more accurately described by the English word "join" than pseudoEnglish "concat". I think there should be no "concat" at all. One of the principle goals of this project is reducing the API.
  • This is basically a question... (>>=) is equivalent to
    concatMap
    in the list monad. I am not exactly a fan of the name, the Scala community uses
    flatMap
    as far as I recall. Should we include the function
    flatMap
    in the monad? Has one advantage, sometimes it's intuitive. I reckon it's intuitive whenever (=<<) is.

--Pirated Dreams 12:38, 28 December 2006 (UTC)

If we really want to go for consistency, then perhaps 'joinMap'? --Nmessenger 00:05, 4 January 2007 (UTC)
joinMap
is consistent in that is says what it does :)
flatMap
would have introduced it (
join . map
) as a bit more sophisticated concept (highlighting the map underneath the monadic container). Doesn't really matter. Thanks for pulling
(>>)
up. I am not aware of any caveats, though the experts may jump in and say "you see, this and that are the reasons we didn't do it ..." and ruin the day ;) --Pirated Dreams 11:02, 4 January 2007 (UTC)

3 Duplicate definitions

I found out that we have been duplicating Gofer's prelude here :p

Also, projecting the future, I see we'll be seeing duplicate definitions in the prelude (like
map
and
(.)
). I think we can do something here. Mostly, this renaming is worthwhile for one reason: sometimes they are useful as operators, sometimes as functions. I think we should keep one of them inside the class, the other outside. This guarantees that they mean exactly the same thing. This provides cleaner documentation and consistency. If someone wants to provide an alternative defintion of
(.)
(say) s/he can hide it from the prelude. --Pirated Dreams 11:11, 4 January 2007 (UTC)
should
<*>
be named
*>>
? the current is symmetric-looking but the meaning is not. --Pirated Dreams 20:37, 22 January 2007 (UTC)
The
Applicative
class in the
Control.Applicative
module names this function
(*>)
. I'm not sure if this is better than its name in
Monad
or not. My current inclination is
(>>)
for backwards compatibility, but that's not so important in this exercise. Re: duplicate names; I've thought about this a little, and the same argument could be applied to any class that defines methods in terms of each other.
(<)
,
(<=)
,
(>)
, and
(>=)
could be lifted from
Ord
(and defined in terms of
compare
),
(>>)
/
(*>)
from
Applicative
,
join
from
Monad
, etc. I'm not sure where to draw the line, so I'd defer it. --Nick Messenger 16:45, 3 February 2007 (UTC)