Personal tools

Upgrading packages

From HaskellWiki

(Difference between revisions)
Jump to: navigation, search
(Upgrading packages moved to Upgrading packages/Updating to GHC 6.10: This version applies to the older GHC 6.10. It is out-of-date for GHC-7.0)
 
m (tweak .cabal conditional example)
(3 intermediate revisions by 2 users not shown)
Line 1: Line 1:
#REDIRECT [[Upgrading packages/Updating to GHC 6.10]]
+
A list of things that need updating when porting packages to newer library/cabal versions.
  +
  +
If you maintain a Haskell package this is for you.
  +
For older versions of this document:
  +
  +
* [[/Updating to GHC 6.10]]
  +
* [[/Updating to GHC 6.8]]
  +
  +
  +
'''Updating to GHC 7.0'''
  +
  +
When upgrading to GHC 7.0, any of your packages that worked against
  +
the base-3 library will need to be updated to the base-4.
  +
  +
'''Compatibility with older GHC'''
  +
  +
Use cabal's conditional thingy, checking on impl(ghc >= x.yz). E.g:
  +
  +
ghc-options: -Wall -fexcess-precision -funbox-strict-fields
  +
if impl(ghc >= 6.12)
  +
ghc-options: -fno-warn-unused-do-bind
  +
  +
  +
(This is a stub, since the previous version was so out-of-date. Please help by adding useful content.)

Revision as of 12:41, 15 December 2011

A list of things that need updating when porting packages to newer library/cabal versions.

If you maintain a Haskell package this is for you. For older versions of this document:


Updating to GHC 7.0

When upgrading to GHC 7.0, any of your packages that worked against the base-3 library will need to be updated to the base-4.

Compatibility with older GHC

Use cabal's conditional thingy, checking on impl(ghc >= x.yz). E.g:

   ghc-options:         -Wall -fexcess-precision -funbox-strict-fields
   if impl(ghc >= 6.12)
       ghc-options:     -fno-warn-unused-do-bind


(This is a stub, since the previous version was so out-of-date. Please help by adding useful content.)