Personal tools

WxHaskell/2.9

From HaskellWiki

< WxHaskell(Difference between revisions)
Jump to: navigation, search
(Prerequisites: Corrected MSYS version)
Line 5: Line 5:
 
* '''Windows''': You will need wx-config for Windows, MinGW 5.1.6 and MSYS 0.1.11 (these are the latest versions at the time of writing). You must select the C++ compiler option when installing MinGW.
 
* '''Windows''': You will need wx-config for Windows, MinGW 5.1.6 and MSYS 0.1.11 (these are the latest versions at the time of writing). You must select the C++ compiler option when installing MinGW.
 
** MinGW 5.1.6 can be downloaded from [http://sourceforge.net/projects/mingw/files/Automated%20MinGW%20Installer MinGW]
 
** MinGW 5.1.6 can be downloaded from [http://sourceforge.net/projects/mingw/files/Automated%20MinGW%20Installer MinGW]
** MSYS 0.1.11 can be downloaded from [http://downloads.sourceforge.net/mingw/MSYS-1.0.11.exe MSYS]
+
** MSYS 1.0.11 can be downloaded from [http://downloads.sourceforge.net/mingw/MSYS-1.0.11.exe MSYS]
 
** wx-config can be downloaded from [http://wxconfig.googlepages.com/ wx-config]
 
** wx-config can be downloaded from [http://wxconfig.googlepages.com/ wx-config]
 
* '''Mac OS X''': you need to install the <tt>gcc</tt> compiler, which is part of the Apple Developer Tools.
 
* '''Mac OS X''': you need to install the <tt>gcc</tt> compiler, which is part of the Apple Developer Tools.

Revision as of 20:37, 5 June 2012

1 Prerequisites

Ensure you have a recent GHC compiler – version 7.0 or higher is recommended.

  • Windows: You will need wx-config for Windows, MinGW 5.1.6 and MSYS 0.1.11 (these are the latest versions at the time of writing). You must select the C++ compiler option when installing MinGW.
    • MinGW 5.1.6 can be downloaded from MinGW
    • MSYS 1.0.11 can be downloaded from MSYS
    • wx-config can be downloaded from wx-config
  • Mac OS X: you need to install the gcc compiler, which is part of the Apple Developer Tools.

At the time of writing, there are few pre-packaged wxWidgets 2.9.x libraries, so you are best just downloading the latest version from The wxWidgets website.

We assume in this guide that the variable $wxwin points to your wxWidgets installation directory, for example: ~/dev/wxGTK-2.8.10.

2 Building wxWidgets

MacOS X Lion: I built wxWidgets with most of the optional libraries as follows:

./configure --enable-unicode --disable-debug --with-osx_cocoa
            --prefix=/usr/local --enable-stc --enable-aui
            --enable-propgrid --enable-xrc --enable-ribbon
            --enable-richtext --enable-webkit --with-opengl
make && make install

Windows 7: I built wxWidgets as follows:

Edit wxwidgets-src-dir\build\msw\config.gcc so that the following values are set:

SHARED ?= 1
BUILD ?= release

Then (in cmd.exe, not bash):

cd wxwidgets-src-dir\build\msw
mingw32-make -f makefile.gcc

The required wx-config for building on Windows with wxWidgets 2.9.x is currently hosted on Sourceforge - binary only and as source code on code.haskell.org, and only obtainable if you pull the complete repository. The version of wx-config at code.google.com will not work (it is only suitable for wxWidgets 2.8.x)