Personal tools

Yi/FAQ

From HaskellWiki

< Yi(Difference between revisions)
Jump to: navigation, search
 
Line 12: Line 12:
 
;Setup configure fails with
 
;Setup configure fails with
 
"Setup.hs: Package yi-0.3 can't be built on this system."
 
"Setup.hs: Package yi-0.3 can't be built on this system."
:it means that you have no UI package available. See DEPENDENCIES.
+
:it means that you have no UI package available. You need vty or gtk2hs installed. Get them from hackage.
   
   

Revision as of 12:02, 31 January 2008

1 Installation

How do I install yi?
get it from hackage. Configure, compile and install yi as you would do for any other Cabal package.
Setup.hs does not compile!
You need to use Cabal version 1.2.3. To make sure you use it, do:
   ghc -package Cabal-1.2.3.0 --make Setup.hs
   ./Setup configure ...
Setup configure fails with
"Setup.hs: Package yi-0.3 can't be built on this system."
it means that you have no UI package available. You need vty or gtk2hs installed. Get them from hackage.


2 Configuration

3 Usage