Personal tools

Yi/FAQ

From HaskellWiki

< Yi(Difference between revisions)
Jump to: navigation, search
Line 3: Line 3:
 
*How do I install Yi?
 
*How do I install Yi?
 
:get it from Hackage. Configure, compile and install Yi as you would do for any other Cabal package.
 
:get it from Hackage. Configure, compile and install Yi as you would do for any other Cabal package.
  +
  +
*Setup configure fails with
  +
Setup.hs: Package yi-0.4 can't be built on this system.
  +
:It means that you have no UI package available. You need VTY or GTK2hs installed. Get them from Hackage.
  +
  +
*cabal install yi fails with dependency errors, eg:
  +
$ cabal install yi
  +
Resolving dependencies...
  +
cabal.exe: dependencies conflict: ghc-6.8.3 requires bytestring ==0.9.0.1.1
  +
however
  +
bytestring-0.9.0.1.1 was excluded because bytestring-0.9.0.1 was selected
  +
instead
  +
bytestring-0.9.0.1.1 was excluded because yi-0.3 requires bytestring =0.9.0.1
  +
:Try removing all your old yi packages, and do
  +
cabal update
  +
before attempting to install.
   
 
*cabal install -fghcAPI fails
 
*cabal install -fghcAPI fails
Line 10: Line 26:
 
cabal build
 
cabal build
 
cabal copy
 
cabal copy
 
*Setup configure fails with
 
Setup.hs: Package yi-0.4 can't be built on this system.
 
:It means that you have no UI package available. You need VTY or GTK2hs installed. Get them from Hackage.
 
   
 
*On Mac OS X if you get an error message similar to this:
 
*On Mac OS X if you get an error message similar to this:

Revision as of 16:31, 27 July 2008

Contents

1 Installation

  • How do I install Yi?
get it from Hackage. Configure, compile and install Yi as you would do for any other Cabal package.
  • Setup configure fails with
Setup.hs: Package yi-0.4 can't be built on this system.
It means that you have no UI package available. You need VTY or GTK2hs installed. Get them from Hackage.
  • cabal install yi fails with dependency errors, eg:
$ cabal install yi
Resolving dependencies...
cabal.exe: dependencies conflict: ghc-6.8.3 requires bytestring ==0.9.0.1.1
however
bytestring-0.9.0.1.1 was excluded because bytestring-0.9.0.1 was selected
instead
bytestring-0.9.0.1.1 was excluded because yi-0.3 requires bytestring =0.9.0.1
Try removing all your old yi packages, and do
cabal update

before attempting to install.

  • cabal install -fghcAPI fails
If you want GHC API special capabilities, you have to download, configure, build and copy separately:
cd yi
cabal configure -fghcAPI
cabal build
cabal copy
  • On Mac OS X if you get an error message similar to this:
yi: can't load .so/.DLL for: gthread-2.0 (dlopen(libgthread-2.0.dylib, 10): image not found)
then your dynamic library search path variable is probably not set correctly. You can set it (in Bash) using:
export DYLD_LIBRARY_PATH=/opt/local/lib
(Adjust the specific path to your system. You can find the right location using locate libgthread)

1.1 Development

  • How do I install Yi for development?
Get it from http://code.haskell.org/yi while there are other repositories of Yi out there, this is the latest.
  • What are some of the dependancies?
The development version of Yi currently requires Cabal-1.4, fingertree-0.0, and utf8-string-0.3.1.
If you are on Mac OS X and are using MacPorts, then these will not be included in the GHC in that distribution. Many of the dependancies are in MacPorts (for example: ghc, ghc-devel, alex, and gtk2hs). However, you may have some trouble building with Cabal-1.5.2, since it is a development version of Cabal. To work around these issues, you might have to add the line "Build-Type: Simple" to the .cabal files in the above required packages.

2 Configuration

2.1 How to Configure Yi

You can find configuration file examples in the 'examples/' directory, or online at http://code.haskell.org/yi/examples/.

A good way to start is to copy yi.hs in your ~/.yi directory (create it if needed), and hack as needed.

3 Usage