As a work-around for packages that want parsec 2, as the cabal system allows multiple versions of a library to be installed, could one just go ahead and install a parsec 2 and let Cabal packages select that?  Perhaps name the Arch package &quot;parsec2&quot; in the PKGBUILD so it doesn&#39;t conflict with parsec 3 when having pacman install it.  Or just cabal-install.<br>
<br><div class="gmail_quote">On Mon, Jan 25, 2010 at 4:31 PM, Leif Warner <span dir="ltr">&lt;<a href="mailto:abimelech@gmail.com">abimelech@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
I&#39;ve just been taking the &quot;&lt; 3&quot; requirement for parsec out of .cabal files - I&#39;ve found most things still compile with the new version.<br>Is it safe to assume it still works if it compiles, or is there a danger in doing this?<br>
<font color="#888888">
-Leif</font><div><div></div><div class="h5"><br><br><div class="gmail_quote">On Sun, Jan 24, 2010 at 6:15 PM, Don Stewart <span dir="ltr">&lt;<a href="mailto:dons@galois.com" target="_blank">dons@galois.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
The version of parsec in [extra] is 3.x, which isn&#39;t part of the Haskell Platform.<br>
This means a lot of stuff doesn&#39;t build :/<br>
<br>
Are there any apps (darcs??) that need parsec3? If not, we should switch<br>
to parsec 2<br>
<br>
vegai?<br>
<br>
-- Don<br>
_______________________________________________<br>
arch-haskell mailing list<br>
<a href="mailto:arch-haskell@haskell.org" target="_blank">arch-haskell@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/arch-haskell" target="_blank">http://www.haskell.org/mailman/listinfo/arch-haskell</a><br>
</blockquote></div><br>
</div></div></blockquote></div><br>