I was trying to add the IDE Leksah, and some of the parts have dependencies on specific versions of haddock.  Haddock is provided by the ghc package, but it&#39;s not listed in ghc-pkg list.  I can take the lines mentioning haddock dependencies out of .cabal files (since that&#39;s provided anyways), but some of the source files, e.g. line 150 of src/IDE/Metainfo/SourceCollectorH.hs in the leksah-server package, have cpp directives like:<div>
 #if MIN_VERSION_haddock(2,8,0)</div><div><br></div><div>Is there some kind of workaround for this?  Let it know haddock is already there?  Patch those files myself to the appropriate haddock version?</div><div><br></div>
<div>-Leif Warner</div>