<div class="gmail_quote">Hi all,<br>Is that latest Yesod + mime-mail broken or am I doing something stupid?  I can install everything just fine but when I do<br><br>&gt; yesod init<br>&gt; Project Name: test<br>&gt; Foundation: Test<br>
&gt; cd test<br>
&gt; cabal configure<br><br>I get<br>Resolving dependencies...<br>Configuring test-0.0.0...<br>cabal: At least the following dependencies are missing:<br>mime-mail &gt;=0.3.0.3 &amp;&amp; &lt;0.4<br><br>However<br><br>&gt; pacman -Ss haskell-mime-mail<br>

haskell/haskell-mime-mail 0.3.0-3 [installed]<br>    Compose MIME email messages.<br><br>Note the &#39;-&#39; in the third place where there was a &#39;.&#39; in the third place on the &#39;cabal configure&#39; command.<br>

<br>If I &#39;cabal install&#39; mime-mail this only results in more confusion and breakage for cabal, as you might expect.<br><br>&gt; cabal install &#39;mime-mail &lt;0.4&#39;<br>Resolving dependencies...<br>(... Snip ...)<br>

Registering mime-mail-0.3.0.3...<br><br>&gt; cabal configure<br>Resolving dependencies...<br>Configuring personal-website-0.0.0...<br>Warning: This package indirectly depends on multiple versions of the same<br>package. This is highly likely to cause a compile failure.<br>

package mime-mail-0.3.0 requires dataenc-0.13.0.4<br>package mime-mail-0.3.0.3 requires dataenc-0.14.0.3<br>package yesod-auth-0.7.5 requires mime-mail-0.3.0<br>package personal-website-0.0.0 requires mime-mail-0.3.0.3<br>

<br>It seems I can&#39;t use the current version of yesod that&#39;s in the Arch Haskell repositories because of this.  Any suggestions?<br>Thanks,<br>Andrew<br>
</div><br>