<html>
  <head>
    <meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    On 02/15/2012 10:28 AM, Adrien Haxaire wrote:
    <blockquote cite="mid:64c9c98a12560272e30c87080a52e165@haxaire.org"
      type="cite">On Tue, 14 Feb 2012 13:01:05 +0100, Magnus Therning
      wrote:
      <br>
      <blockquote type="cite">Start with cleaning up your ah-ghc74
        directory (you can use `git
        <br>
        clean` for that) and make sure you have `cblrepo` in your path. 
        Then
        <br>
        the following steps ought to do the job:
        <br>
        <br>
            $ cd ah-ghc74
        <br>
            $ cblrepo build $(cblrepo list | cut -f1 -d\ ) &gt;
        ,,build-order
        <br>
            $ cblrepo pkgbuild $(cat ,,build-order)
        <br>
            $ ./makeahpkg -x -- ghc $(cat ,,build-order)
        <br>
        <br>
      </blockquote>
      <br>
      Seems it built successfully.
      <br>
      <br>
      I started with a cblrepo sync to initialize it. Here are the
      files/directories in my ah-ghc74 directory after running the
      scripts:
      <br>
      <br>
        ,,build-order
      <br>
        cblrepo.db
      <br>
        ghc
      <br>
        haskell-ansi-terminal
      <br>
        haskell-ansi-wl-pprint
      <br>
        haskell-cereal
      <br>
        haskell-cmdargs
      <br>
        haskell-crypto-api
      <br>
        haskell-darcs-beta
      <br>
        haskell-data-default
      <br>
        haskell-dataenc
      <br>
        haskell-entropy
      <br>
        haskell-hashed-storage
      <br>
        haskell-haskeline
      <br>
        haskell-html
      <br>
        haskell-hunit
      <br>
        haskell-json
      <br>
        haskell-largeword
      <br>
        haskell-mmap
      <br>
        haskell-mtl
      <br>
        haskell-parallel
      <br>
        haskell-parsec
      <br>
        haskell-primitive
      <br>
        haskell-puremd5
      <br>
        haskell-random
      <br>
        haskell-regex-base
      <br>
        haskell-regex-compat
      <br>
        haskell-regex-posix
      <br>
        haskell-regex-tdfa
      <br>
        haskell-semigroups
      <br>
        haskell-split
      <br>
        haskell-syb
      <br>
        haskell-tagged
      <br>
        haskell-tar
      <br>
        haskell-text
      <br>
        haskell-transformers
      <br>
        haskell-unixutils
      <br>
        haskell-utf8-string
      <br>
        haskell-vector
      <br>
        haskell-x11
      <br>
        haskell-xmonad
      <br>
        haskell-xmonad-contrib
      <br>
        haskell-xmonad-extras
      <br>
        haskell-zlib
      <br>
        i686-chroot
      <br>
        makeahpkg
      <br>
        patches
      <br>
      <br>
      I made a copy of it for safety, then tried to install it:
      <br>
      <br>
      sudo pacman -U ghc/ghc-7.4.1-1-i686.pkg.tar.xz
      <br>
      Mot de passe :
      <br>
      chargement des paquets…
      <br>
      résolution des dépendances...
      <br>
      recherche des conflits entre paquets...
      <br>
      Erreur : la préparation de la transaction a échoué (la
      satisfaction des dépendances a échoué)
      <br>
      :: haskell-cpphs : requiert ghc=7.0.3-2
      <br>
      :: haskell-ghc-paths : requiert ghc=7.0.3-2
      <br>
      :: haskell-haskell-src-exts : requiert ghc=7.0.3-2
      <br>
      :: haskell-hlint : requiert ghc=7.0.3-2
      <br>
      :: haskell-hscolour : requiert ghc=7.0.3-2
      <br>
      :: haskell-hscolour : requiert haskell-containers=0.4.0.0
      <br>
      :: haskell-hunit : requiert ghc=7.0.3-2
      <br>
      :: haskell-json : requiert ghc=7.0.3-2
      <br>
      :: haskell-json : requiert haskell-array=0.3.0.2
      <br>
      :: haskell-json : requiert haskell-bytestring=0.9.1.10
      <br>
      :: haskell-json : requiert haskell-containers=0.4.0.0
      <br>
      :: haskell-json : requiert haskell-pretty=1.0.1.2
      <br>
      :: haskell-mtl : requiert ghc=7.0.3-2
      <br>
      :: haskell-parsec : requiert ghc=7.0.3-2
      <br>
      :: haskell-primitive : requiert ghc=7.0.3-2
      <br>
      :: haskell-quickcheck : requiert ghc=7.0.3-2
      <br>
      :: haskell-syb : requiert ghc=7.0.3-2
      <br>
      :: haskell-transformers : requiert ghc=7.0.3-2
      <br>
      :: haskell-uniplate : requiert ghc=7.0.3-2
      <br>
      :: haskell-vector : requiert ghc=7.0.3-2
      <br>
      :: haskell-xhtml : requiert ghc=7.0.3-2
      <br>
      <br>
      It says it cannot resolve the dependencies, namely ghc 7.0.3-2,
      but ghc --version gives: The Glorious Glasgow Haskell Compilation
      System, version 7.0.3.
      <br>
      <br>
      Any clue? I did not update my arch for a while, maybe this is why.
      <br>
    </blockquote>
    OK, I do not know French but it looks like you have some packages
    installed which depend on the old version of ghc.<br>
    Remove the old ghc <b>and all the packages which depend on it</b>
    beofre installing 7.4.1.<br>
    <br>
    Peter.<br>
    <br>
  </body>
</html>