It is possible and desirable to manage haskell packages with pacman on Arch Linux!<br>It is just not perfect yet - the arch-haskell project needs your help. Perhaps you could point Ian Ross this way too.<br>(For me personally, using the [haskell] and [haskell-extra] repositories has worked out well so far, and it&#39;s nice knowing everything is managed properly by pacman.)<br>

<br><div class="gmail_quote">On Mon, Oct 15, 2012 at 5:16 PM, Mateusz Loskot <span dir="ltr">&lt;<a href="mailto:mateusz@loskot.net" target="_blank">mateusz@loskot.net</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

<div class="im">On 15 October 2012 11:00, Thomas Friedrich &lt;<a href="mailto:info@suud.de">info@suud.de</a>&gt; wrote:<br>
&gt; 2012/10/13 Fabio Riga &lt;<a href="mailto:rifabio@gmail.com">rifabio@gmail.com</a>&gt;:<br>
&gt;&gt; 2012/10/13 Ramana Kumar &lt;<a href="mailto:ramana@member.fsf.org">ramana@member.fsf.org</a>&gt;<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; I&#39;m not sure why that error happened but it happened to me too.<br>
&gt;&gt;<br>
&gt;&gt; The problem seems to be that those files were not part of any package,<br>
&gt;&gt; but now are in ghc.<br>
&gt;&gt;<br>
&gt;&gt;&gt; I removed the offending files manually and tried again, and ran into more problems (although everything installed, there were many warnings about interface files<br>
&gt;&gt;&gt; being the wrong version and being skipped).<br>
&gt;&gt;&gt; So I&#39;m not sure what the correct way out is. Perhaps it will require some manual removals then reinstalls.<br>
&gt;&gt;<br>
&gt;&gt; This is a problem with ghc-pkg version. For previous version of ghc I had to do:<br>
&gt;&gt;<br>
&gt;&gt;   $ pacman -Rcs ghc<br>
&gt;&gt;<br>
&gt;&gt; then reinstall ghc and needed haskell-* packages. I think you&#39;ll want<br>
&gt;&gt; to remove the offending files before installing ghc again. I hope this<br>
&gt;&gt; solve the problem.<br>
&gt;<br>
&gt;<br>
</div><div class="im">&gt; Why is it that every single time there is a ghc-update, I have to<br>
&gt; remove everything and reinstall everything haskell related. Haskell is<br>
&gt; such a cool language but keeping a Haskell environment up-to-date is<br>
&gt; sometimes just a real pain.<br>
<br>
</div>As Haskell newbie and new born Hakyll users, I&#39;ve found recent<br>
replies [1] by Ian Ross interesting:<br>
<br>
&quot;I&#39;m also using Arch Linux on x86_64.  I would strongly recommend *not*<br>
using the Arch packages for most Haskell things.  I use hsenv instead.&quot;<br>
<br>
I haven&#39;t switched myself and I still use the packages, but I started to<br>
wonder if Ian&#39;s got the point indeed.<br>
<br>
[1] <a href="https://groups.google.com/d/topic/hakyll/9G1qXBA4raU/discussion" target="_blank">https://groups.google.com/d/topic/hakyll/9G1qXBA4raU/discussion</a><br>
<div class="im HOEnZb"><br>
Best regards,<br>
--<br>
Mateusz Loskot, <a href="http://mateusz.loskot.net" target="_blank">http://mateusz.loskot.net</a><br>
<br>
</div><div class="HOEnZb"><div class="h5">_______________________________________________<br>
arch-haskell mailing list<br>
<a href="mailto:arch-haskell@haskell.org">arch-haskell@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/arch-haskell" target="_blank">http://www.haskell.org/mailman/listinfo/arch-haskell</a><br>
</div></div></blockquote></div><br>