[Haskell-beginners] Important coding guideline and library proposal

Michael Snoyman michael at snoyman.com
Sun Nov 22 14:32:13 EST 2009


I should think the more obvious examples would be last and init...

Michael

On Sun, Nov 22, 2009 at 9:26 PM, Joe Fredette <jfredett at gmail.com> wrote:

> Well then, on a similar note, I propose the following name changes:
>
>
> (+) is now
> "yesIShouldReallyLikeToKnowTheSumOfTheseTwoThingsOverWhichTheOperationOfSummationIsDulyAndTotallyDefined"
>
> (-) is the same, but with "Summation" changed to
> "AdditiveInverseAndSummation"
>
> the `do` construct ought to be renamed
> "doThisMonadicComputationForMePleaseByDesugaringThisConvienentNotationAndTurningItIntoASequenceOfBindFunctionsAndLambdaAbstractionsSuchThatMyIntendedMeaningInFactIsReflected"
>
> Further, things like "unsafePerformIO" is not nearly descriptive enough,
> however, I leave it's appropriate renaming as an exercise to the reader...
>
> /Joe
>
>
> On Nov 22, 2009, at 2:15 PM, Daniel Fischer wrote:
>
>  Guideline:
>>
>> NEVER, *never ever*, use 'length' ***unless you really want to know the
>> exact length of a
>> list***
>>
>> Proposal:
>> rename 'length' to
>> 'yesIReallyWantToKnowTheExactLengthOfThisListSoPleaseCalculateItForMe'
>> to reduce performance bugs caused by naive uses of length.
>> _______________________________________________
>> Beginners mailing list
>> Beginners at haskell.org
>> http://www.haskell.org/mailman/listinfo/beginners
>>
>
> _______________________________________________
> Beginners mailing list
> Beginners at haskell.org
> http://www.haskell.org/mailman/listinfo/beginners
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/beginners/attachments/20091122/e5532ca9/attachment.html


More information about the Beginners mailing list