[Haskell-beginners] Cannot Install Yi - Haskell 2011.02.0.0
daniel.is.fischer at googlemail.com
Sat Mar 26 13:55:26 CET 2011
On Saturday 26 March 2011 10:33:24, Sayth Renshaw wrote:
> Actually I cannot install Yi on mint debian either. Cabal version
> doesn't match.
> I did cabal install cabal-install
> cabal upgrade cabal
> but get this error when trying to install Yi
> Installing library in /home/sayth/.cabal/lib/Cabal-22.214.171.124/ghc-6.12.1
> Registering Cabal-126.96.36.199...
> sayth at homegroup ~ $ cabal install yi
> Resolving dependencies...
> cabal: dependencies conflict: ghc-6.12.1 requires Cabal ==188.8.131.52
> however Cabal-184.108.40.206 was excluded because yi-0.6.3.0 requires Cabal
Yes, the ghc lib requires the Cabal it was built against. You can either
try installing an earlier version of Yi which works with Cabal-1.8.*
or upgrading to GHC-7 (which comes with Cabal-1.10).
More information about the Beginners