<div> </div>
<div>Dear All,</div>
<div> </div>
<div>After I installed the ghc binary package (ghc-6.12.1-i386-unknown-linux.tar.bz2) manually, I can&#39;t find a way to uninstall it. Could anyone help me out?</div>
<div> </div>
<div>Thanks in advance.</div>
<div> </div>
<div>Kwanghoon</div>
<div> </div>
<div>PS.</div>
<div>I have installed two versions of ghc. One is with the ghc-6.12.1 package, and the other is ghc-6.8.2 package. The former is downloaded to be installed manually, but the latter is done automatically by using APT tool. They are installed in a different way. I mean the ghc-6.12.1 is under /usr/local/bin, but ghc-6.8.2 is under /usr/bin. (Of course, you can change this default setting though)</div>

<div> </div>
<div>My original purpose is to install the newest QuickCheck package. Having both ghc packages seems to cause a conflict. After I try with $ runhaskell Setup.lhs configure, I met a dependency error requiring me to install mtl (monad transformer library). I did install by APT tool. But the retrial with $ runhaskell Setup.lhs configure does not work because the configuration is being done by ghc-6.12.1 package. The ghc-6.12.1 package doesn&#39;t recognize the presence of mtl package that I installed just before. Only the ghc-6.8.2 package seems to recognize the presence of mtl package. The mtl package seems to be built aligned with ghc-6.8.2 package. I guess this strange phenomena comes from the different configuration of the two versions. </div>

<div> </div>
<div>This is the reason why I try to uninstall ghc-6.12.1, but it doesn&#39;t seem to provide any way to be uninstalled, unfortunately. If I am wrong, please correct me.</div>