Yes, I read the thread you made. Working on a hunch I downloaded the Gtk+ all in one bundle and installed it but used all the environment variables defined by the glade installer (I just changed GTK_HOME to the newly downloaded all in one bundle and updated the other variables as needed). This seems to have fixed the libraries not being found, but it now looks like I&#39;m being bitten by another issue entirely. I&#39;m getting the following error:<br>
Registering cairo-0.12.0...<br>Installing library in<br>C:\Users\Kyle\AppData\Roaming\cabal\cairo-0.12.0\ghc-7.0.2<br>Registering cairo-0.12.0...<br>setup.exe: internal error: unexpected package db stack: [UserPackageDB]<br>
<br>What&#39;s weird is that I found a ticket for cabal that&#39;s similar to this one (<a href="http://hackage.haskell.org/trac/hackage/ticket/731">http://hackage.haskell.org/trac/hackage/ticket/731</a>) but it&#39;s specifically in the case of using a custom package db which I don&#39;t think I&#39;m doing (unless the gtk package is doing something really weird). Maybe this is a more general issue with the latest version of Cabal? Just in case the output from running cabal --version:<br>
<br>cabal-install version 0.10.2<br>using version 1.10.1.0 of the Cabal library<br><br>I&#39;m going to keep experimenting and hopefully find a way to get this all working.<br><br clear="all">-R. Kyle Murphy<br>--<br>Curiosity was framed, Ignorance killed the cat.<br>

<br><br><div class="gmail_quote">On Fri, Mar 18, 2011 at 19:23, aditya siram <span dir="ltr">&lt;<a href="mailto:aditya.siram@gmail.com">aditya.siram@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
Hi Kyle,<br>
I ran into this exact issue and fixed it on my Windows box at work but<br>
I forgot how. I won&#39;t be back there till Monday, can I get back to you<br>
then?<br>
<br>
If this is still an issue could send me email on Monday morning to remind me?<br>
<br>
thanks...<br>
-deech<br>
<div><div></div><div class="h5"><br>
On Fri, Mar 18, 2011 at 5:49 PM, Kyle Murphy &lt;<a href="mailto:orclev@gmail.com">orclev@gmail.com</a>&gt; wrote:<br>
&gt; I&#39;m trying to follow the instructions provided on<br>
&gt; <a href="http://www.haskell.org/haskellwiki/Gtk2Hs" target="_blank">http://www.haskell.org/haskellwiki/Gtk2Hs</a> to install Gtk2Hs in Windows 7 (64<br>
&gt; bit) and running into problems.<br>
&gt; Originally I was trying to get wxHaskell installed, but it kept crashing<br>
&gt; trying to build the monolithic library due to an apparent bug in the latest<br>
&gt; port of GCC, so after talking with some of the people in #haskell I was<br>
&gt; advised that Gtk2Hs was better supported and might be easier to get working.<br>
&gt; For the most part, that appears to be true but I (as well as several others<br>
&gt; it seems) am running into a problem where cabal can&#39;t seem to find quite a<br>
&gt; few of the Gtk+ libraries (specifically z, cairo, gobject, glib, and intl).<br>
&gt; Near as I can tell everything should be functioning, and running pkg-config<br>
&gt; --modversion glib-2.0 outputs &quot;2.20.3&quot; so at least pkg-config seems to be<br>
&gt; able to find glib. Looking in the Gtk+\lib\pkgconfig folder I see pc files<br>
&gt; for everything but z and intl listed. Running cabal install<br>
&gt; gtk2hs-buildtools also succeeds, it&#39;s only when I get to the cabal install<br>
&gt; gtk step that things fail.<br>
&gt;<br>
&gt; cmd console output for the usual environment variables:<br>
&gt;<br>
&gt; INCLUDE: C:\libxml\include;C:\Program Files (x86)\Gtk+\include<br>
&gt; LIB: C:\libxml\lib;C:\Program Files (x86)\Gtk+\lib<br>
&gt; PKG_CONFIG_PATH: C:\libxml\lib\pkgconfig;C:\Program Files<br>
&gt; (x86)\Gtk+\lib\pkgconfig<br>
&gt;<br>
&gt; I trimmed the PATH output below for everyones sanity. The vast majority was<br>
&gt; stuff in the Windows folder or one of dozens of entries dumped in there by<br>
&gt; some version or other of Java.<br>
&gt;<br>
&gt; PATH:<br>
&gt; C:\Program Files (x86)\Haskell\bin;<br>
&gt; C:\Program Files (x86)\Haskell Platform\2011.2.0.0\lib\extralibs\bin;<br>
&gt; C:\Program Files (x86)\Haskell Platform\2011.2.0.0\bin;<br>
&gt; C:\MinGW\bin;<br>
&gt; C:\Users\Kyle\AppData\Roaming\cabal\bin;<br>
&gt; C:\Program Files (x86)\Haskell\bin;<br>
&gt; C:\Program Files (x86)\Gtk+\bin<br>
&gt;<br>
&gt; The exact error I&#39;m getting when building is the following:<br>
&gt; C:\Users\Kyle&gt;cabal install gtk<br>
&gt; Warning: The package list for &#39;<a href="http://hackage.haskell.org" target="_blank">hackage.haskell.org</a>&#39; is 23 days old.<br>
&gt; Run &#39;cabal update&#39; to get the latest list of available packages.<br>
&gt; Resolving dependencies...<br>
&gt; C:\Users\Kyle\AppData\Local\Temp\cairo-0.12.05760\cairo-0.12.0\Gtk2HsSetup.hs:25:2:<br>
&gt; warning: #warning Setup.hs is guessing the version of Cabal. If<br>
&gt; compilationof Setup.hs fails use -DCABAL_VERSION_MINOR=x for Cabal version<br>
&gt; 1.x.0 when building (prefixed by --ghc-option= when using the &#39;cabal&#39;<br>
&gt; command)<br>
&gt; [1 of 2] Compiling Gtk2HsSetup      (<br>
&gt; C:\Users\Kyle\AppData\Local\Temp\cairo-0.12.05760\cairo-0.12.0\Gtk2HsSetup.hs,<br>
&gt; C:\Users\Kyle\AppData\Local\Temp\cairo-0.12.05760\cairo-0.12.0\dist\setup\Gtk2HsSetup.o<br>
&gt; )<br>
&gt; [2 of 2] Compiling Main             (<br>
&gt; C:\Users\Kyle\AppData\Local\Temp\cairo-0.12.05760\cairo-0.12.0\Setup.hs,<br>
&gt; C:\Users\Kyle\AppData\Local\Temp\cairo-0.12.05760\cairo-0.12.0\dist\setup\Main.o<br>
&gt; )<br>
&gt; Linking<br>
&gt; C:\Users\Kyle\AppData\Local\Temp\cairo-0.12.05760\cairo-0.12.0\dist\setup\setup.exe<br>
&gt; ...<br>
&gt; Configuring cairo-0.12.0...<br>
&gt; setup.exe: Missing dependencies on foreign libraries:<br>
&gt; * Missing C libraries: z, cairo<br>
&gt; This problem can usually be solved by installing the system packages that<br>
&gt; provide these libraries (you may need the &quot;-dev&quot; versions). If the libraries<br>
&gt; are already installed but in a non-standard location then you can use the<br>
&gt; flags --extra-include-dirs= and --extra-lib-dirs= to specify where they are.<br>
&gt; C:\Users\Kyle\AppData\Local\Temp\glib-0.12.05760\glib-0.12.0\Gtk2HsSetup.hs:25:2:<br>
&gt; warning: #warning Setup.hs is guessing the version of Cabal. If compilation<br>
&gt; of Setup.hs fails use -DCABAL_VERSION_MINOR=x for Cabal version 1.x.0 when<br>
&gt; building (prefixed by --ghc-option= when using the &#39;cabal&#39; command)<br>
&gt; [1 of 2] Compiling Gtk2HsSetup      (<br>
&gt; C:\Users\Kyle\AppData\Local\Temp\glib-0.12.05760\glib-0.12.0\Gtk2HsSetup.hs,<br>
&gt; C:\Users\Kyle\AppData\Local\Temp\glib-0.12.05760\glib-0.12.0\dist\setup\Gtk2HsSetup.o<br>
&gt; )<br>
&gt; [2 of 2] Compiling Main             (<br>
&gt; C:\Users\Kyle\AppData\Local\Temp\glib-0.12.05760\glib-0.12.0\Setup.hs,<br>
&gt; C:\Users\Kyle\AppData\Local\Temp\glib-0.12.05760\glib-0.12.0\dist\setup\Main.o<br>
&gt; )<br>
&gt; Linking<br>
&gt; C:\Users\Kyle\AppData\Local\Temp\glib-0.12.05760\glib-0.12.0\dist\setup\<br>
&gt; setup.exe ...<br>
&gt; Configuring glib-0.12.0...<br>
&gt; setup.exe: Missing dependencies on foreign libraries:<br>
&gt; * Missing C libraries: gobject-2.0, glib-2.0, intl<br>
&gt; This problem can usually be solved by installing the system packages that<br>
&gt; provide these libraries (you may need the &quot;-dev&quot; versions). If the libraries<br>
&gt; are already installed but in a non-standard location then you can use the<br>
&gt; flags --extra-include-dirs= and --extra-lib-dirs= to specify where they are.<br>
&gt; cabal: permission denied<br>
&gt;<br>
&gt;<br>
&gt; -R. Kyle Murphy<br>
&gt; --<br>
&gt; Curiosity was framed, Ignorance killed the cat.<br>
&gt;<br>
</div></div>&gt; _______________________________________________<br>
&gt; Beginners mailing list<br>
&gt; <a href="mailto:Beginners@haskell.org">Beginners@haskell.org</a><br>
&gt; <a href="http://www.haskell.org/mailman/listinfo/beginners" target="_blank">http://www.haskell.org/mailman/listinfo/beginners</a><br>
&gt;<br>
&gt;<br>
</blockquote></div><br>