<br><br><div class="gmail_quote">On Sat, Mar 26, 2011 at 10:00 PM,  <span dir="ltr">&lt;<a href="mailto:beginners-request@haskell.org">beginners-request@haskell.org</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
Send Beginners mailing list submissions to<br>
        <a href="mailto:beginners@haskell.org">beginners@haskell.org</a><br>
<br>
To subscribe or unsubscribe via the World Wide Web, visit<br>
        <a href="http://www.haskell.org/mailman/listinfo/beginners" target="_blank">http://www.haskell.org/mailman/listinfo/beginners</a><br>
or, via email, send a message with subject or body &#39;help&#39; to<br>
        <a href="mailto:beginners-request@haskell.org">beginners-request@haskell.org</a><br>
<br>
You can reach the person managing the list at<br>
        <a href="mailto:beginners-owner@haskell.org">beginners-owner@haskell.org</a><br>
<br>
When replying, please edit your Subject line so it is more specific<br>
than &quot;Re: Contents of Beginners digest...&quot;<br>
<br>
<br>
Today&#39;s Topics:<br>
<br>
   1.  Cannot Install Yi - Haskell 2011.02.0.0 (Sayth Renshaw)<br>
   2. Re:  Cannot Install Yi - Haskell 2011.02.0.0 (Jeff Wheeler)<br>
   3. Re:  Cannot Install Yi - Haskell 2011.02.0.0 (Sayth Renshaw)<br>
<br>
<br>
----------------------------------------------------------------------<br>
<br>
Message: 1<br>
Date: Sat, 26 Mar 2011 18:59:52 +1100<br>
From: Sayth Renshaw &lt;<a href="mailto:flebber.crue@gmail.com">flebber.crue@gmail.com</a>&gt;<br>
Subject: [Haskell-beginners] Cannot Install Yi - Haskell 2011.02.0.0<br>
To: <a href="mailto:beginners@haskell.org">beginners@haskell.org</a><br>
Message-ID:<br>
        &lt;AANLkTikKe=<a href="mailto:2acBD-mNaVPkX77WmfPOdF8Xxh9MEVpfia@mail.gmail.com">2acBD-mNaVPkX77WmfPOdF8Xxh9MEVpfia@mail.gmail.com</a>&gt;<br>
Content-Type: text/plain; charset=&quot;iso-8859-1&quot;<br>
<br>
Hi I am on Windows XP SP3. The unix chain fails to install and therefore i<br>
cannot install Yi.<br>
<br>
This is how it is failing. Any ideas on how to get it working?<br>
<br>
Registering dyre-0.8.6...<br>
Installing library in C:\Documents and Settings\renshaw\Application<br>
Data\cabal\dyre-0.8.6\ghc-7.0.2<br>
Registering dyre-0.8.6...<br>
cabal: Error: some packages failed to install:<br>
terminfo-0.3.1.3 failed during the configure step. The exception was:<br>
ExitFailure 1<br>
unix-2.4.2.0 failed during the configure step. The exception was:<br>
ExitFailure 1<br>
vty-4.6.0.6 depends on unix-2.4.2.0 which failed to install.<br>
yi-0.6.3.0 depends on unix-2.4.2.0 which failed to install.<br>
-------------- next part --------------<br>
An HTML attachment was scrubbed...<br>
URL: &lt;<a href="http://www.haskell.org/pipermail/beginners/attachments/20110326/68be8871/attachment-0001.htm" target="_blank">http://www.haskell.org/pipermail/beginners/attachments/20110326/68be8871/attachment-0001.htm</a>&gt;<br>

<br>
------------------------------<br>
<br>
Message: 2<br>
Date: Sat, 26 Mar 2011 03:04:07 -0500<br>
From: Jeff Wheeler &lt;<a href="mailto:wheele11@illinois.edu">wheele11@illinois.edu</a>&gt;<br>
Subject: Re: [Haskell-beginners] Cannot Install Yi - Haskell<br>
        2011.02.0.0<br>
To: <a href="mailto:beginners@haskell.org">beginners@haskell.org</a>, <a href="mailto:yi-devel@googlegroups.com">yi-devel@googlegroups.com</a><br>
Message-ID:<br>
        &lt;<a href="mailto:AANLkTin8TWrzkuZRKMtyMP6mnZuAPqCV3R0Fzw5wbnuC@mail.gmail.com">AANLkTin8TWrzkuZRKMtyMP6mnZuAPqCV3R0Fzw5wbnuC@mail.gmail.com</a>&gt;<br>
Content-Type: text/plain; charset=UTF-8<br>
<br>
On Sat, Mar 26, 2011 at 2:59 AM, Sayth Renshaw &lt;<a href="mailto:flebber.crue@gmail.com">flebber.crue@gmail.com</a>&gt; wrote:<br>
&gt; Hi I am on Windows XP SP3. The unix chain fails to install and therefore i<br>
&gt; cannot install Yi.<br>
<br>
The vty UI is not supported on Windows, unfortunately. You&#39;ll need to<br>
install Gtk2Hs and the Pango UI. I&#39;m not sure if there&#39;s anything you<br>
need to do to install Gtk2Hs (on unix machines, it&#39;s just cabal<br>
install-able), but after that you should be able to run this:<br>
<br>
$ cabal install yi -f-vty -fpango<br>
<br>
(That disables the vty UI, enables the pango UI.)<br>
<br>
--<br>
Jeff Wheeler<br>
<br>
Undergraduate, Electrical Engineering<br>
University of Illinois at Urbana-Champaign<br>
<br>
<br>
<br>
------------------------------<br>
<br>
Message: 3<br>
Date: Sat, 26 Mar 2011 20:33:24 +1100<br>
From: Sayth Renshaw &lt;<a href="mailto:flebber.crue@gmail.com">flebber.crue@gmail.com</a>&gt;<br>
Subject: Re: [Haskell-beginners] Cannot Install Yi - Haskell<br>
        2011.02.0.0<br>
To: <a href="mailto:beginners@haskell.org">beginners@haskell.org</a><br>
Message-ID:<br>
        &lt;AANLkTikWGQOH95U=<a href="mailto:8f55ZT%2Bdrf3MrCTTxwjY5621ddq7@mail.gmail.com">8f55ZT+drf3MrCTTxwjY5621ddq7@mail.gmail.com</a>&gt;<br>
Content-Type: text/plain; charset=&quot;iso-8859-1&quot;<br>
<br>
On Sat, Mar 26, 2011 at 6:59 PM, Sayth Renshaw &lt;<a href="mailto:flebber.crue@gmail.com">flebber.crue@gmail.com</a>&gt;wrote:<br>
<br>
&gt; Hi I am on Windows XP SP3. The unix chain fails to install and therefore i<br>
&gt; cannot install Yi.<br>
&gt;<br>
&gt; This is how it is failing. Any ideas on how to get it working?<br>
&gt;<br>
&gt; Registering dyre-0.8.6...<br>
&gt; Installing library in C:\Documents and Settings\renshaw\Application<br>
&gt; Data\cabal\dyre-0.8.6\ghc-7.0.2<br>
&gt; Registering dyre-0.8.6...<br>
&gt; cabal: Error: some packages failed to install:<br>
&gt; terminfo-0.3.1.3 failed during the configure step. The exception was:<br>
&gt; ExitFailure 1<br>
&gt; unix-2.4.2.0 failed during the configure step. The exception was:<br>
&gt; ExitFailure 1<br>
&gt; vty-4.6.0.6 depends on unix-2.4.2.0 which failed to install.<br>
&gt; yi-0.6.3.0 depends on unix-2.4.2.0 which failed to install.<br>
&gt;<br>
<br>
Actually I cannot install Yi on mint debian either. Cabal version doesn&#39;t<br>
match.<br>
<br>
I did cabal install cabal-install<br>
then<br>
cabal upgrade cabal<br>
<br>
but get this error when trying to install Yi<br>
<br>
Installing library in /home/sayth/.cabal/lib/Cabal-1.10.1.0/ghc-6.12.1<br>
Registering Cabal-1.10.1.0...<br>
sayth@homegroup ~ $ cabal install yi<br>
Resolving dependencies...<br>
cabal: dependencies conflict: ghc-6.12.1 requires Cabal ==1.8.0.2 however<br>
Cabal-1.8.0.2 was excluded because yi-0.6.3.0 requires Cabal ==1.10.*<br>
-------------- next part --------------<br>
An HTML attachment was scrubbed...<br>
URL: &lt;<a href="http://www.haskell.org/pipermail/beginners/attachments/20110326/e55d3703/attachment-0001.htm" target="_blank">http://www.haskell.org/pipermail/beginners/attachments/20110326/e55d3703/attachment-0001.htm</a>&gt;<br>

<br>
------------------------------<br>
<br>
_______________________________________________<br>
Beginners mailing list<br>
<a href="mailto:Beginners@haskell.org">Beginners@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/beginners" target="_blank">http://www.haskell.org/mailman/listinfo/beginners</a><br>
<br>
<br>
End of Beginners Digest, Vol 33, Issue 36<br>
*****************************************<br>
</blockquote></div><br>The command cabal install-able wouldn&#39;t work for me no package found.<br><br>so I installed gtk and yi-gtk.<br><br>I tried to then use.<br>$ cabal install yi -f-vty -fpango<br><br>this failed though because among other things glib would not install. from the error messages gtk2hs-buildtools was advised to be installed. So I installed that.<br>
Then I attempted to use $ cabal install yi -f-vty -fpango again but still glib fails.<br><br>glib cannot be installed because of below error. Any further ideas?<br><br>\setup.exe ...<br>Configuring glib-0.12.0...<br>setup.exe: The program pkg-config version &gt;=0.9.0 is required but it could not<br>
be found.<br>cabal: Error: some packages failed to install:<br>glib-0.12.0 failed during the configure step. The exception was:<br>ExitFailure 1<br><br>C:\Documents and Settings\renshaw&gt;cabal install pkg-config<br>cabal: There is no package named &#39;pkg-config&#39;.<br>
You may need to run &#39;cabal update&#39; to get the latest list of available<br>packages.<br><br>Sayth<br><br>