<div class="gmail_quote">On Sat, Sep 24, 2011 at 12:33 PM, csmagic <span dir="ltr">&lt;<a href="mailto:csmagic@gmail.com">csmagic@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<div><div></div><div class="h5"><br><br><div class="gmail_quote">On Sat, Sep 24, 2011 at 12:16 PM, Antoine Latter <span dir="ltr">&lt;<a href="mailto:aslatter@gmail.com" target="_blank">aslatter@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<div>On Sat, Sep 24, 2011 at 1:10 AM, csmagic &lt;<a href="mailto:csmagic@gmail.com" target="_blank">csmagic@gmail.com</a>&gt; wrote:<br>
&gt;<br>
&gt; It seems to be happening elsewhere also:<br>
&gt; <a href="http://hackage.haskell.org/trac/hackage/ticket/856" target="_blank">http://hackage.haskell.org/trac/hackage/ticket/856</a><br>
&gt;<br>
&gt; Also its more likely a locale issue than a terminal one because I get the<br>
&gt; same error when I replace the pipe with a redirection to a file.<br>
&gt;<br>
&gt; And yet my locales dont seem to be odd in any way (I can see)<br>
&gt;<br>
&gt; $ locale<br>
&gt; LANG=en_US<br>
&gt; LANGUAGE=<br>
&gt; LC_CTYPE=&quot;en_US&quot;<br>
&gt; LC_NUMERIC=&quot;en_US&quot;<br>
&gt; LC_TIME=&quot;en_US&quot;<br>
&gt; LC_COLLATE=&quot;en_US&quot;<br>
&gt; LC_MONETARY=&quot;en_US&quot;<br>
&gt; LC_MESSAGES=&quot;en_US&quot;<br>
&gt; LC_PAPER=&quot;en_US&quot;<br>
&gt; LC_NAME=&quot;en_US&quot;<br>
&gt; LC_ADDRESS=&quot;en_US&quot;<br>
&gt; LC_TELEPHONE=&quot;en_US&quot;<br>
&gt; LC_MEASUREMENT=&quot;en_US&quot;<br>
&gt; LC_IDENTIFICATION=&quot;en_US&quot;<br>
&gt; LC_ALL=<br>
&gt;<br>
&gt;<br>
<br>
</div>I would expect a unicode locale to look something like this:<br>
<br>
<a href="http://www.madboa.com/geek/utf8/" target="_blank">http://www.madboa.com/geek/utf8/</a><br>
<br>
So I&#39;m guessing something is not set-up right for unicode output, and<br>
at least one of the Cabal package descriptions includes unicode<br>
output.<br></blockquote></div><br></div></div>Yeah thats it:<br></blockquote></div><br>&lt;snipped&gt;<br><br>Now with cabal working a little better I see that I have a cabal installed uniplate<br>And now I also find a uniplate in the debian apt repos<br>
How do I uninstall the cabal one and switch to the apt one?<br>