<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    Am 27.02.2012 14:05, schrieb Tobias:
    <blockquote cite="mid:4F4B7FA3.1070309@freenet.de" type="cite">I am
      trying to compile a Glade Gtk2Hs demo and I get the same error as
      described at
      <a class="moz-txt-link-freetext" href="http://www.haskell.org/pipermail/haskell-cafe/2010-August/081881.html">http://www.haskell.org/pipermail/haskell-cafe/2010-August/081881.html</a>
      when I try install cabal glade: "setup.exe: The pkg-config package
      libglade-2.0 version &gt;=2.0.0 is required but it could not be
      found." <br>
      The next reply to the email (
      <a class="moz-txt-link-freetext" href="http://www.haskell.org/pipermail/haskell-cafe/2010-August/081941.html">http://www.haskell.org/pipermail/haskell-cafe/2010-August/081941.html</a>
      ) is the interrogator himself again thanking some people who told
      him how to fix that / <br>
      "libglade-2.0.pc needed the edit"- <br>
      <br>
      Can you tell me what I have to edit in this libglade-2.0.pc.file
      and where this file should be? Thanks in advance! <br>
    </blockquote>
    <br>
    Ok, I found the missing replies on
    <a class="moz-txt-link-freetext" href="http://sourceforge.net/mailarchive/forum.php?thread_name=AANLkTinHpb94nqG-Yc24eLd%3D5huWYX77E4vwM1_VsOhh%40mail.gmail.com&amp;forum_name=gtk2hs-users">http://sourceforge.net/mailarchive/forum.php?thread_name=AANLkTinHpb94nqG-Yc24eLd%3D5huWYX77E4vwM1_VsOhh%40mail.gmail.com&amp;forum_name=gtk2hs-users</a>
    and this problem is fixed. Now I run into the next error trying
    "cabal install glade":<br>
    <br>
    <i>Configuring glade-0.12.1...<br>
      setup.exe: Missing dependencies on foreign libraries:<br>
      * Missing C libraries: glade-2.0, gtk-win32-2.0, xml2,
      gdk-win32-2.0, atk-1.0,<br>
      gio-2.0, gdk_pixbuf-2.0, pangowin32-1.0, gdi32, pangocairo-1.0,
      pango-1.0,<br>
      cairo, gobject-2.0, gmodule-2.0, glib-2.0, intl<br>
      This problem can usually be solved by installing the system
      packages that<br>
      provide these libraries (you may need the "-dev" versions). If the
      libraries<br>
      are already installed but in a non-standard location then you can
      use the<br>
      flags --extra-include-dirs= and --extra-lib-dirs= to specify where
      they are.<br>
      cabal: Error: some packages failed to install:<br>
      glade-0.12.1 failed during the configure step. The exception was:<br>
      ExitFailure 1</i><br>
    <br>
    as described also here:
    <a class="moz-txt-link-freetext" href="http://comments.gmane.org/gmane.comp.lang.haskell.gtk2hs/2781">http://comments.gmane.org/gmane.comp.lang.haskell.gtk2hs/2781</a><br>
    <br>
    where should the above described libraries be located? at
    ..\Gtk+\lib ? <br>
    I think some of them are there ( pango-1.0.lib ) but some of them
    are not ( glade-2.0 (?)<i>).<br>
    </i>However, when I run "cabal install gtk" it says "No packages to
    be installed. All the requested packages are already installed."<br>
    <br>
    can anyone help me?<br>
    <br>
    <br>
  </body>
</html>