<html><head></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">Hi Gregory, just been looking at your thread here&nbsp;<div>(We seem to be having somewhat parallel problems - I am struggling with installing wxHAskell on mac osx).<div><br></div><div>I was wondering, if you give the command&nbsp;"wx-config --release"<div><div>What do you get ?</div></div><div>If it says 2.8 (which is what I get) then presumably your 'path' is still pointing to the earlier version. And this would fit with Heinrich Apfelmus's</div><div>comments ?</div><div><br></div><div>I am struggling to make sense of path settings, and I raised some questions in another thread/s.</div><div><br></div><div>In the wxHaskell installation instructions for wxWidgets 2.8 &nbsp;I saw this:</div><div><span class="Apple-style-span" style="font-family: 'Helvetica Neue', Arial, Helvetica, sans-serif; line-height: 22px; ">"We assume in this guide that the variable&nbsp;</span><span class="Apple-style-span" style="font-family: 'Helvetica Neue', Arial, Helvetica, sans-serif; line-height: 22px; "><tt style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; padding-top: 0px; padding-right: 0px; padding-bottom: 0px; padding-left: 0px; font-family: monospace; line-height: 16px; ">$wxwin</tt></span><span class="Apple-style-span" style="font-family: 'Helvetica Neue', Arial, Helvetica, sans-serif; line-height: 22px; ">&nbsp;points to your wxWidgets installation directory, for example:&nbsp;</span><span class="Apple-style-span" style="font-family: 'Helvetica Neue', Arial, Helvetica, sans-serif; line-height: 22px; "><tt style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; padding-top: 0px; padding-right: 0px; padding-bottom: 0px; padding-left: 0px; font-family: monospace; line-height: 16px; ">~/dev/wxGTK-2.8.10</tt></span><span class="Apple-style-span" style="font-family: 'Helvetica Neue', Arial, Helvetica, sans-serif; line-height: 22px; ">."</span></div><div></div><div>It is not in a windows specific part of the instructions, though I wonder (from the name) if it is just relevant for windows (though 'win' could also</div><div>denote 'Widgets INstallation' perhaps).</div><div><br></div><div>Do you recognise $wxwin (and what is it set to in your case?).</div><div>I wonder if this may be implicated in the path settings for 2.9 too.</div><div><br></div><div>I was also very interested by your "If the libraries</div>&nbsp;&nbsp;&nbsp;&nbsp;are already installed but in a non-standard location then you can use the<br>&nbsp;&nbsp;&nbsp;&nbsp;flags --extra-include-dirs= and --extra-lib-dirs= to specify where they are."</div><div><br></div><div>I have not got to the cabal step yet (still trying to reach some confidence I have widgets installed and configured correctly!) but it seems this</div><div>may be the (at least an) answer to the path aspect if all else fails with trying to get an auto default path working.<br><div><br></div><div>Cheers/ Henry</div><div><br></div><div><br><div><div>On 6 Jun 2012, at 21:15, Gregory Guthrie wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><div><blockquote type="cite"><blockquote type="cite">First, you should make sure for yourself that wxWidgets 2.9 is well installed, for that you can try to build the wxwidgets' examples<br></blockquote></blockquote><br><blockquote type="cite"><blockquote type="cite">cd c:\wx\samples\minimal<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">mingw32-make -f makefile.gcc BUILD=debug <br></blockquote></blockquote><br>Thanks, good test, it fails.<br><br> &nbsp;&nbsp;&nbsp;&nbsp;/e/plang/libraries/wxWidgets2.9/samples/minimal &gt;<br> &nbsp;&nbsp;&nbsp;&nbsp;$ mingw32-make -f makefile.gcc BUILD=debug<br> &nbsp;&nbsp;&nbsp;&nbsp;if not exist gcc_mswuddll mkdir gcc_mswuddll<br> &nbsp;&nbsp;&nbsp;&nbsp;windres --use-temp-file -i../../samples/sample.rc -ogcc_mswuddll\minimal_sample_rc.o &nbsp;&nbsp;&nbsp;--define __WXMSW__ &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;--define _UNICODE &nbsp;-- &nbsp;&nbsp;&nbsp;&nbsp;include-dir .\..\..\lib\gc<br> &nbsp;&nbsp;&nbsp;&nbsp;c_dll\mswud --include-dir ./../../include &nbsp;--include-dir . --define WXUSINGDLL --include-dir ./../../samples --define NOPCH<br> &nbsp;&nbsp;&nbsp;&nbsp;g++ -c -o gcc_mswuddll\minimal_minimal.o -g -O0 -mthreads &nbsp;-DHAVE_W32API_H -D__WXMSW__ &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;-D_UNICODE &nbsp;-I.\..\..\lib\gcc_dll\mswud -I.\..\..\include &nbsp;-W -Wall<br> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;-I. -DWXUSINGDLL -I.\..\..\samples -DNOPCH &nbsp;&nbsp;-Wno-ctor-dtor-privacy &nbsp;&nbsp;-MTgcc_mswuddll\minimal_minimal.o &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;-MFgcc_mswuddll\minimal_minimal.o.d -MD -MP minimal.cpp<br><br> &nbsp;&nbsp;&nbsp;&nbsp;In file included from .\..\..\include/wx/defs.h:28:0,<br> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;from .\..\..\include/wx/wxprec.h:13,<br> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;from minimal.cpp:21:<br> &nbsp;&nbsp;&nbsp;&nbsp;.\..\..\include/wx/platform.h:181:22: fatal error: wx/setup.h: No such file or directory<br> &nbsp;&nbsp;&nbsp;&nbsp;compilation terminated.<br> &nbsp;&nbsp;&nbsp;&nbsp;mingw32-make: *** [gcc_mswuddll\minimal_minimal.o] Error 1<br><br>(I did have to start a mingw shell to do this, it won't run from a cmd line.)<br>Not sure what to make of it...<br><br>I still wish I could just get a binary to install like was available from wxPack for 2.8! &nbsp;:-)<br><br>----<br><blockquote type="cite">Then, I can think that it is just a problem of configuring and installing wxhaskell.<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">For the paths you have to set, probably the wxc is not installed on your pc yet, and probably that's why you couldn't find. <br></blockquote><blockquote type="cite">But you should follow the way setting those paths and put the right versions of the libraries you are installing.<br></blockquote><br>Yes, probably wxc is not installed, but that is the problem I am stuck at I think.<br><br>_______________________________________________<br>Beginners mailing list<br><a href="mailto:Beginners@haskell.org">Beginners@haskell.org</a><br>http://www.haskell.org/mailman/listinfo/beginners<br></div></blockquote></div><br></div></div></div></body></html>