I see that this this trac item has no milestone and an &quot;unknown&quot; duration. Has this problem (incompatibility of large libraries and ghci on the Mac) slipped through the cracks? Is it thought to be unimportant? For me, not being able to count on ghci is a huge detriment. Thanks,<br>

<br>  - Conal<br>
<br><div class="gmail_quote">On Sun, Mar 20, 2011 at 9:18 PM, Hackage <span dir="ltr">&lt;<a href="mailto:cvs-ghc@haskell.org" target="_blank">cvs-ghc@haskell.org</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">


<div>#791: Large libraries not installable on OS X<br>
-----------------------------+----------------------------------------------<br>
  Reporter:  batterseapower  |        Owner:<br>
      Type:  defect          |       Status:  new<br>
  Priority:  high            |    Milestone:<br>
 Component:  Cabal library   |      Version:  1.8.0.6<br>
  Severity:  normal          |     Keywords:<br>
Difficulty:  unknown         |   Ghcversion:<br>
  Platform:  Mac OS          |<br>
-----------------------------+----------------------------------------------<br>
</div>Changes (by conal):<br>
<br>
 * cc: conal (added)<br>
<br>
<br>
Comment:<br>
<br>
 I just ran into this same issue while &#39;cabal install&#39;ing highlighting-<br>
 kate-0.2.9 with 32-bit ghc 7.0.2 on Mac OS 10.6.6. Is there an up-to-date<br>
 recommendation for this problem?<br>
 {{{<br>
 bash-3.2$ pwd<br>
 /Users/conal/cabal/highlighting-kate-0.2.9<br>
 bash-3.2$ cabal install<br>
 Resolving dependencies...<br>
 Configuring highlighting-kate-0.2.9...<br>
 Preprocessing library highlighting-kate-0.2.9...<br>
 Preprocessing executables for highlighting-kate-0.2.9...<br>
 Building highlighting-kate-0.2.9...<br>
 [  1 of 111] Compiling Paths_highlighting_kate (<br>
 dist/build/autogen/Paths_highlighting_kate.hs,<br>
 dist/build/Paths_highlighting_kate.o )<br>
 ...<br>
 [111 of 111] Compiling Text.Highlighting.Kate ( Text/Highlighting/Kate.hs,<br>
 dist/build/Text/Highlighting/Kate.o )<br>
<div> ld: scattered reloc r_address too large<br>
</div> cabal: Error: some packages failed to install:<br>
 highlighting-kate-0.2.9 failed during the building phase. The exception<br>
 was:<br>
 ExitFailure 1<br>
 bash-3.2$ ghc --version<br>
 The Glorious Glasgow Haskell Compilation System, version 7.0.2<br>
 bash-3.2$ uname -a<br>
 Darwin Conals-Mac.local 10.6.0 Darwin Kernel Version 10.6.0: Wed Nov 10<br>
 18:13:17 PST 2010; root:xnu-1504.9.26~3/RELEASE_I386 i386<br>
 }}}<br>
<font color="#888888"><br>
--<br>
Ticket URL: &lt;<a href="http://hackage.haskell.org/trac/hackage/ticket/791#comment:7" target="_blank">http://hackage.haskell.org/trac/hackage/ticket/791#comment:7</a>&gt;<br>
</font><div><div></div><div>Hackage &lt;<a href="http://haskell.org/cabal/" target="_blank">http://haskell.org/cabal/</a>&gt;<br>
Hackage: Cabal and related projects<br>
<br>
_______________________________________________<br>
cabal-devel mailing list<br>
<a href="mailto:cabal-devel@haskell.org" target="_blank">cabal-devel@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/cabal-devel" target="_blank">http://www.haskell.org/mailman/listinfo/cabal-devel</a><br>
</div></div></blockquote></div><br>