ghc-6.12.3 package base - build failure on ubuntu10.10 (works with 10.4)

Mischa Dieterle dieterle at Mathematik.Uni-Marburg.de
Tue Oct 19 10:38:54 EDT 2010


  Hi,

I compared  libraries/base/aclocal.m4 of the HEAD and 6.12 branch and 
found the difference:

< [AS_VAR_PUSHDEF([ac_Search], [ac_cv_search_$3])dnl
---
 > [AS_VAR_PUSHDEF([ac_Search], [ac_cv_search_$1])dnl

This was changed by patch:

Thu Aug 19 22:48:58 CEST 2010  Ross Paterson <ross at soi.city.ac.uk>
   * fix cache variable name used by FP_SEARCH_LIBS_PROTO

I applied the patch to 6.12 what solved the problem.

But you won't even come to that point (compiling whole ghc and not only 
base) without the patch for ticket #4252 which is missing in 6.12. I 
reported this already with ticket #4402 
(http://hackage.haskell.org/trac/ghc/ticket/4402#comment:3).

Cheers,
Mischa


Am 19.10.2010 16:05, schrieb Ryan Newton:
> Usually I get undefined references wrt iconv (similar to the below 
> post) not a failure at configure time.
>
> http://www.mail-archive.com/[email protected]/msg77195.html
>
> Although I have seen seemingly spurious "Missing C libraries" errors 
> before (for example, when I tried building on windows under cygwin and 
> I got that same message regarding libs "rt" and "dl" -- which were 
> indeed present in /usr/lib!).
>
> I am going to upgrade to ubuntu 10.10 today so I'll let you know if I 
> run into the same thing.
>
> -Ryan
>
>
> On Tue, Oct 19, 2010 at 9:41 AM, Simon Marlow <marlowsd at gmail.com 
> <mailto:marlowsd at gmail.com>> wrote:
>
>     On 15/10/2010 16:35, Mischa Dieterle wrote:
>
>         Hi,
>
>         I'm getting a build failure when I try to compile ghc-6.12
>         from the
>         http://darcs.haskell.org/ghc-6.12 repo.
>
>
>         ----
>         ghc-cabal: Missing dependency on a foreign library:
>         * Missing C library: iconv
>         This problem can usually be solved by installing the system
>         package that
>         provides this library (you may need the "-dev" version). If
>         the library is
>         already installed but in a non-standard location then you can
>         use the flags
>         --extra-include-dirs= and --extra-lib-dirs= to specify where
>         it is.
>         make[1]: *** [libraries/base/dist-install/package-data.mk
>         <http://package-data.mk>] Error 1
>         make: *** [all] Error 2
>         ----
>
>
>         I'm using a ubuntu 10.10-64 bit system with libc-bin and
>         libc-dev-bin
>         installed. I don't think the problem is a missing iconv
>         library. Maybe
>         the problem is in the generated configure script by the new
>         autoconf
>         version (autoconf version is 2.67).
>
>
>     I haven't encountered this problem, but I'm not using Ubuntu 10.10
>     yet.  Please report the bug on the Trac so we don't forget about it.
>
>     Cheers,
>            Simon
>
>
>
>         Maybe someone can help.
>
>         Cheers,
>         Mischa
>
>         Stderr output of ./configure on base module is:
>
>         ./configure: line 8709: ${ac_cv_search_iconv_t_cd_
>         ______________________cd___iconv_open_____
>         ______________________iconv_cd_NULL_NULL_NULL_NULL__
>         ______________________iconv_close_cd__+set}: bad substitution
>         ./configure: line 8735: ac_cv_search_iconv_t_cd_: command not
>         found
>         ./configure: line 8736:
>         ______________________cd___iconv_open_____:
>         command not found
>         ./configure: line 8737:
>         ______________________iconv_cd_NULL_NULL_NULL_NULL__: command
>         not found
>         ./configure: line 8742: ${ac_cv_search_iconv_t_cd_
>         ______________________cd___iconv_open_____
>         ______________________iconv_cd_NULL_NULL_NULL_NULL__
>         ______________________iconv_close_cd__+set}: bad substitution
>         ./configure: line 8742: ${ac_cv_search_iconv_t_cd_
>         ______________________cd___iconv_open_____
>         ______________________iconv_cd_NULL_NULL_NULL_NULL__
>         ______________________iconv_close_cd__+set}: bad substitution
>         ./configure: line 8746: ${ac_cv_search_iconv_t_cd_
>         ______________________cd___iconv_open_____
>         ______________________iconv_cd_NULL_NULL_NULL_NULL__
>         ______________________iconv_close_cd__+set}: bad substitution
>         ./configure: line 8746: ac_cv_search_iconv_t_cd_: command not
>         found
>         ./configure: line 8747:
>         ______________________cd___iconv_open_____:
>         command not found
>         ./configure: line 8748:
>         ______________________iconv_cd_NULL_NULL_NULL_NULL__: command
>         not found
>         ./configure: line 8751:
>         ______________________cd___iconv_open_____:
>         command not found
>
>
>
>
>         _______________________________________________
>         Glasgow-haskell-users mailing list
>         Glasgow-haskell-users at haskell.org
>         <mailto:Glasgow-haskell-users at haskell.org>
>         http://www.haskell.org/mailman/listinfo/glasgow-haskell-users
>
>
>     _______________________________________________
>     Glasgow-haskell-users mailing list
>     Glasgow-haskell-users at haskell.org
>     <mailto:Glasgow-haskell-users at haskell.org>
>     http://www.haskell.org/mailman/listinfo/glasgow-haskell-users
>
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/glasgow-haskell-users/attachments/20101019/4298ea93/attachment-0001.html


More information about the Glasgow-haskell-users mailing list