<br><br><div class="gmail_quote">On Sat, Jan 28, 2012 at 10:56 AM, Johan Tibell <span dir="ltr">&lt;<a href="mailto:johan.tibell@gmail.com">johan.tibell@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div class="im">On Sat, Jan 28, 2012 at 6:52 AM, Sanket Agrawal<br>
&lt;<a href="mailto:sanket.agrawal@gmail.com">sanket.agrawal@gmail.com</a>&gt; wrote:<br>
&gt; The reason I am asking is I want to try LLVM backend but GHC keeps<br>
&gt; complaining about missing llvm tools (opt, llc). I checked LLVM webpage but<br>
&gt; couldn&#39;t find information about how to determine what llvm tools are<br>
&gt; installed on my Mac. My guess is XCode 4.1 comes with llvm backend for GCC,<br>
&gt; but not standalone LLVM tools that GHC needs, and that upgrading to XCode<br>
&gt; 4.2 would give me LLVM 3.0 tools as well. Please correct me if I got it<br>
&gt; wrong.<br>
<br>
</div>I just downloaded the LLVM binaries and put them somewhere on my PATH.</blockquote><div><br></div><div>Yes, that is another possibility. I would like to keep it simple, and just upgrade to XCode 4.2, instead of installing Clang+LLVM binaries separately, if it is not an issue for GHC.</div>
</div><br>