<div dir="ltr">Heck if we wanted to bikeshed the name, even 'Holes' would do. ;)</div><div class="gmail_extra"><br><br><div class="gmail_quote">On Mon, Jan 13, 2014 at 4:30 PM, Daniil Frumin <span dir="ltr"><<a href="mailto:difrumin@gmail.com" target="_blank">difrumin@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">On ghc-dev Dominique Devriese has actually proposed changing TypeHoles<br>
to TypedHoles or to something similar, because "TypeHoles" sounds like<br>
you can have holes in types, just like in your example.<br>
<br>
But what error message do you want to get if you have a hole in your<br>
type? GHC won't be able to tell you much<br>
<div class="HOEnZb"><div class="h5"><br>
On Tue, Jan 14, 2014 at 12:54 AM, Mateusz Kowalczyk<br>
<<a href="mailto:fuuzetsu@fuuzetsu.co.uk">fuuzetsu@fuuzetsu.co.uk</a>> wrote:<br>
> On 13/01/14 18:42, Krzysztof Gogolewski wrote:<br>
>> Hello,<br>
>><br>
>> As discussed on ghc-devs, I propose to enable -XTypeHoles in GHC by<br>
>> default. Rationale:<br>
>><br>
>> (1) This way holes are far easier to use; just entering "_" allows to check<br>
>> type of a subexpression, no need of adding "-XTypeHoles".<br>
>><br>
>> (2) This affects error messages only; i.e. the set of programs that compile<br>
>> stays the same - Haskell 2010. The only exception is that if you use<br>
>> -fdefer-type-errors, then a program with a hole compiles, but this seems<br>
>> fine with philosophy of -fdefer-type-errors.<br>
>><br>
>> If so: would you like it to be in 7.8 or wait a cycle? My preference is<br>
>> 7.8, two people (John and Richard) suggested 7.10.<br>
>><br>
>> -KG<br>
>><br>
><br>
> Sounds good. Are there plans to allow TypeHoles to actually sit in place<br>
> of types? In the past I did<br>
><br>
> ```<br>
> data Hole<br>
><br>
> hole :: Hole<br>
> hole = undefined<br>
><br>
> foo :: Integer -> Integer<br>
> foo x = hole<br>
><br>
> bar :: Integer -> Hole<br>
> bar x y = x + y<br>
> ```<br>
><br>
> to cause type errors that could guide me. I now don't have to resort to<br>
> the first use in ‘foo’ but I still have to define my own Hole type in ‘bar’.<br>
><br>
><br>
> --<br>
> Mateusz K.<br>
> _______________________________________________<br>
> Glasgow-haskell-users mailing list<br>
> <a href="mailto:Glasgow-haskell-users@haskell.org">Glasgow-haskell-users@haskell.org</a><br>
> <a href="http://www.haskell.org/mailman/listinfo/glasgow-haskell-users" target="_blank">http://www.haskell.org/mailman/listinfo/glasgow-haskell-users</a><br>
<br>
<br>
<br>
</div></div><span class="HOEnZb"><font color="#888888">--<br>
Sincerely yours,<br>
-- Daniil<br>
</font></span><div class="HOEnZb"><div class="h5">_______________________________________________<br>
Glasgow-haskell-users mailing list<br>
<a href="mailto:Glasgow-haskell-users@haskell.org">Glasgow-haskell-users@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/glasgow-haskell-users" target="_blank">http://www.haskell.org/mailman/listinfo/glasgow-haskell-users</a><br>
</div></div></blockquote></div><br></div>