Haskell 6.0 install

David Roundy [email protected]
Mon, 1 Sep 2003 08:08:55 -0400


On Mon, Sep 01, 2003 at 06:37:29AM -0500, Mark Espinoza wrote:
> Hello,
> 
>  I let make run while I was sleeping on my redhat 7.3 system
> and in the morning it seemed to have worked. I ran make install
> which also seemed to work. Now when I type ghc --help it tells
> me about "ghc-5.04.2". Does this mean that I am still running
> ghc 5?  What can I do if I am still running ghc 5? Will it
> cause me any serious problems if I start going through "An
> Introduction To Functional Programming Systems Using Haskell"
> and deal with it later? Thanks.

You can try running with ghc6 rather than ghc.  ghc 6 and 5 can be
installed in parallel without problems, and if you're writing pure haskell
98 with no extensions (as I imagine the book does), you should be able to
use either one with no problems.
-- 
David Roundy
http://www.abridgegame.org