[Haskell-cafe] Re: ANNOUNCE: deepseq-220.127.116.11
marlowsd at gmail.com
Thu Nov 19 07:17:43 EST 2009
On 19/11/2009 11:52, Sittampalam, Ganesh wrote:
> Yitzchak Gale wrote:
>> Simon Marlow wrote:
>>> So then what shall we call the a -> () version?
>>> One possibility is to go back to calling it rnf.
>> In light of apfelmus' comment, I vote for rnf.
>> And in that case, how about the analogous alternative for seq itself:
>> hnf :: a -> ()
> I think it would be whnf since it doesn't evaluate under lambdas.
> I also vote for rnf, because we should have a good reason for changing
> names of things.
Various people would prefer rnf.
Ok, unless there are any further objections, I'll change the names back to
class NFData a where
rnf :: a -> ()
and also add
deepseq :: a -> b -> b
but I'll leave the module name as Control.DeepSeq.
More information about the Haskell-Cafe