[Haskell-cafe] Maybe to Either -- is there a better way?
gale at sefer.org
Tue Aug 3 05:51:57 EDT 2010
>> maybeToEither = flip maybe Right . Left
Ivan Lazar Miljenovic wrote:
> Remember, some people don't like flip! :p
> maybeToEither = (`maybe` Right) . Left
>> ...go ahead and upload it to Hackage
> Just give it a good name, rather than "fooToolkit", "barToolkit", etc.
How about calling it "fgl"?
No, please don't really. I'm just teasing Ivan.
More information about the Haskell-Cafe