[Haskell-cafe] Sifflet dependencies
dons at galois.com
Mon Aug 16 15:56:34 EDT 2010
$ cabal update
Downloading the latest package list from hackage.haskell.org
$ cabal install sifflet
cabal: cannot configure pango-0.11.1. It requires cairo >=0.11.1 && <0.12 and glib >=0.11.1 && <0.12
For the dependency on cairo >=0.11.1 && <0.12 there are these packages:
cairo-0.11.1. However none of them are available.
cairo-0.11.1 was excluded because sifflet-lib-1.0 requires cairo ==0.11.0
cairo-0.11.1 was excluded because cairo-0.11.0 was selected instead
cairo-0.11.1 was excluded because sifflet-1.0 requires cairo ==0.11.0
For the dependency on glib >=0.11.1 && <0.12 there are these packages:
glib-0.11.1. However none of them are available.
glib-0.11.1 was excluded because sifflet-lib-1.0 requires glib ==0.11.0
glib-0.11.1 was excluded because glib-0.11.0 was selected instead
glib-0.11.1 was excluded because sifflet-1.0 requires glib ==0.11.0
So that's pretty simple. 'sifflet' requires cairo ==0.11.0 and pango. But since
pango doesn't work with cairo 0.11.0, the package can't be built. The solution
is to ask the sifflet author to adjust the dependencies to be more flexible.
Those specific versions of packages are overly constrained. They should follow the PVP, and be thus,
More information about the Haskell-Cafe