[Haskell-cafe] Cabal bug?
duncan.coutts at googlemail.com
Mon Jan 11 10:23:46 EST 2010
On Mon, 2010-01-11 at 13:33 +0100, Henk-Jan van Tuyl wrote:
> I had a strange response from Cabal:
> >cabal upgrade hlint
> Resolving dependencies...
> cabal: cannot configure containers-0.3.0.0. It requires base >=4.2 && <6
> For the dependency on base >=4.2 && <6 there are these packages:
> However none of them are available.
> base-220.127.116.11 was excluded because of the top level dependency base -any
> So, base-18.104.22.168 cannot be used, because any version of base is OK? Is
> this a bug in Cabal?
It's a bug in the sense that the error message is misleading. What it
actually means is "base-22.214.171.124 cannot be used, because an installed
version of base is required". The pretty printing for "installed
constraints" (as opposed to version constraints) is borked.
More information about the Haskell-Cafe