[Haskell-cafe] Is 'flip' really necessary?

Nils ml at n-sch.de
Mon Jul 26 16:42:39 EDT 2010


On 26.07.2010 08:33, David Virebayre wrote:
> listeEtagTot = concatMap (`listeEtagArm` cfgTypesTringle) listeArmOrd

You can use flip as a "wildcard" aswell:

 > listeEtagTot = concatMap (listeEtagArm `flip` cfgTypesTringle) 
listeArmOrd

Makes it even more readable in my opinion, since this really "shows" you 
where the value belongs to.


More information about the Haskell-Cafe mailing list