[Haskell-cafe] Is 'flip' really necessary?

aditya siram aditya.siram at gmail.com
Mon Jul 26 16:53:51 EDT 2010


That's just cool. I now reverse my original statement - 'flip' does have
it's place in the pantheon of standard Haskell functions.

-deech

On Mon, Jul 26, 2010 at 3:42 PM, Nils <ml at n-sch.de> wrote:

> On 26.07.2010 08:33, David Virebayre wrote:
>
>> listeEtagTot = concatMap (`listeEtagArm` cfgTypesTringle) listeArmOrd
>>
>
> You can use flip as a "wildcard" aswell:
>
> > listeEtagTot = concatMap (listeEtagArm `flip` cfgTypesTringle)
> listeArmOrd
>
> Makes it even more readable in my opinion, since this really "shows" you
> where the value belongs to.
>
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20100726/cc6a1b75/attachment.html


More information about the Haskell-Cafe mailing list