[Haskell-cafe] Again, version conflicting problem with cabal-install
Felipe Almeida Lessa
felipe.lessa at gmail.com
Fri Feb 3 17:31:27 CET 2012
On Fri, Feb 3, 2012 at 2:22 PM, Andres Löh <andres.loeh at googlemail.com> wrote:
> A controlled way of ignoring version constraints (mainly upper bounds,
> actually) is certainly on my TODO list for the new solver. The main
> issue to work out is a good way how to control the disabled bounds via
> the command line, because you usually don't want to ignore all of
> them. Currently, my UI-preference is a flag
> with the semantics that all dependencies on foo will be changed to
> allow foo-1.3 to be chosen. Would that be ok? Other suggestions?
Can't this be integrated with the current --constraint flag? If the
constraint is able to be satisfied without unrestricting any bounds,
fine. Otherwise, unrestrict any bounds on that constraint. What
would be the drawbacks?
An advantage is being able to specify --constraint='foo >= 1.3' to get
foo-22.214.171.124 instead of having to find out exactly which version you
want. And if you already know what you want, you may always say
--constraint='foo == 126.96.36.199'.
Looking forward to the new solver! =)
More information about the Haskell-Cafe