To back him up, it seems that the lhaskell.vim syntax highlighter is broken with Vim 7.1. Here, it is definitely using lhaskell.vim, but doesn't seem to be parsing the code in between \begin{code} and \end{code} as Haskell. 
<br><br>I can&#39;t work out why though, it seems that the addition of \@= to the end pattern of the code region is causing it to not be recognised, but removing it causes other problems.<br><br>Adding the keepend option makes it work nicely for the first block, but fail to highlight later blocks.
<br><br><div><span class="gmail_quote">On 05/06/07, <b class="gmail_sendername">Ilya Tsindlekht</b> &lt;<a href="mailto:eilya497@013.net">eilya497@013.net</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
On Tue, Jun 05, 2007 at 04:58:40PM +0800, Michael T. Richter wrote:<br>&gt; I&#39;ve given up on getting a decent text editor for editing Haskell<br>&gt; (specifically literate Haskell -- plain Haskell works fine in GEDIT).
<br>&gt; Instead I fire up VIM and get ... a total mess.&nbsp;&nbsp;At first I think maybe<br>&gt; I&#39;ve screwed up a whole bunch of settings or something, so I nuke<br>&gt; everything in my home directory that begins with .vim and then, for
<br>&gt; added measure, head over to /usr/share and nuke the entire ./vim<br>&gt; directory tree.&nbsp;&nbsp;I then reinstall vim (from the Ubuntu Edgy archives) to<br>&gt; get a brand new set of config files unsullied by my hands.
<br>&gt;<br>&gt; I still get a dog&#39;s breakfast.<br>&gt;<br>&gt; A screen shot of what I&#39;m seeing with a representative example of a .lhs<br>&gt; file to show what I mean can be found at<br>&gt; <a href="http://img357.imageshack.us/img357/5798/gvimexamplezv4.png">
http://img357.imageshack.us/img357/5798/gvimexamplezv4.png</a>.&nbsp;&nbsp;(I&#39;ve pared<br>&gt; it down to the minimum I could find that shows the behaviour clearly.)<br>&gt; The problems I&#39;m seeing are the ugly white-on-red for underlines, the
<br>&gt; lack of any kind of differentiation for keywords/operators/etc. vs.<br>&gt; identifiers (although some punctuation is recognized, specifically curly<br>&gt; braces), comments not being noted, etc.&nbsp;&nbsp;Basically it looks like the
<br>&gt; Haskell is simply not being recognized at all (and, if the @saBinds@<br>&gt; thing is what I think it is, it looks like some latex isn&#39;t being<br>&gt; recognized fully either).<br>&gt;<br>&gt; Can anybody vim-centric please take a look at this and give me a few
<br>&gt; educated guesses as to what is happening here?&nbsp;&nbsp;For good measure, here&#39;s<br>&gt; the beginning of the lhaskell.vim file that comes with my vim<br>&gt; distribution (7.0 in the Ubuntu archives).&nbsp;&nbsp;If it&#39;s desired I can attach
<br>&gt; the whole file.&nbsp;&nbsp;(It isn&#39;t actually all that large.)<br>It seems to me like VIM thinks your file is a (La)TeX file. Can you<br>check that your filetype variable is set to lhaskell? (Type :set filetype)<br>It should be if your file has extension .lhs. If it isn&#39;t, try setting it
<br>manually (:set filetype=lhaskell)<br>_______________________________________________<br>Haskell-Cafe mailing list<br><a href="mailto:Haskell-Cafe@haskell.org">Haskell-Cafe@haskell.org</a><br><a href="http://www.haskell.org/mailman/listinfo/haskell-cafe">
http://www.haskell.org/mailman/listinfo/haskell-cafe</a><br></blockquote></div><br>