<br><br>&nbsp;&nbsp; Hi all,<br><br>I am writing a program that uses hmatrix for solving some linear systems. The hmatrix package depends on BLAS, which, in turn, depend on GCC 4.2 to be built (at least ATLAS does).<br><br>GHC 6.10 for Windows is pre-packaged with GCC 3.4.5, and it leaves me with the impression that I would have incompatible ABIs.<br>
<br>My questions:<br><br>1) Why GHC 6.10 still uses GCC 3.4.5 in Windows? I know mingw considers GCC 4.2 to be alpha, but, lets face it, 4.2 is almost obsolete!<br>2) Is it possible to rebuild GHC 6.10, using Windows and GCC 4.2? Is there any guide for doing this?<br>
3) Has any of you tried hmatrix on Windows? How did you do it?<br><br>Thanks,<br><br>Rafael<br clear="all"><br>-- <br>Rafael Gustavo da Cunha Pereira Pinto<br>Electronic Engineer, MSc.<br>