Hi,<br><br>I have tried to install the newest available binary distribution of GHC for AIX (6.8.2).<br>Unfortunately, it didn&#39;t work properly. Following the trivial installation steps as described<br>in INSTALL file I executed the following commands:<br>
<br>    1) ./configure --prefix=/home/nik/local<br>    2) gmake install<br><br>But I got the following error message:<br>--------------------------------------------------------------------------------------------------------------------------------------<br>
....<br>Reading package info from stdin ... done.<br>warning: can&#39;t find GHCi lib HSrts.o<br>Saving old package config file... done.<br>Writing new package config file... done.<br>/tmp/ghc-6.8.2/utils/mkdirhier/mkdirhier /home/nik/local/ghc-6.8.2/lib/ghc-6.8.2<br>
for i in libHSrts*.a ; do \<br>        case $i in \<br>          *.a) \<br>            /tmp/ghc-6.8.2/install-sh -c -m 644    $i /home/nik/local/ghc-6.8.2/lib/ghc-6.8.2; \<br>            : /home/nik/local/ghc-6.8.2/lib/ghc-6.8.2/`basename $i` ;; \<br>
          *.dll) \<br>            /tmp/ghc-6.8.2/install-sh -c -m 644   -s  $i /home/nik/local/ghc-6.8.2/lib/ghc-6.8.2 ;; \<br>          *.so) \<br>            /tmp/ghc-6.8.2/install-sh -c -m 755    $i /home/nik/local/ghc-6.8.2/lib/ghc-6.8.2 ;; \<br>
          *.dylib) \<br>            /tmp/ghc-6.8.2/install-sh -c -m 755    $i /home/nik/local/ghc-6.8.2/lib/ghc-6.8.2; \<br>            install_name_tool -id /home/nik/local/ghc-6.8.2/lib/ghc-6.8.2/`basename $i` /home/nik/local/ghc-6.8.2/lib/ghc-6.8.2/`basename $i` ;; \<br>
          *) \<br>            /tmp/ghc-6.8.2/install-sh -c -m 644    $i /home/nik/local/ghc-6.8.2/lib/ghc-6.8.2; \<br>        esac; \<br>done<br>gmake[1]: Leaving directory `/tmp/ghc-6.8.2/rts&#39;<br>gmake -C libraries install      DOING_BIN_DIST=YES<br>
gmake[1]: Entering directory `/tmp/ghc-6.8.2/libraries&#39;<br>if ifBuildable/ifBuildable base; then \<br>  cd base &amp;&amp; \<br>  ../installPackage/installPackage &#39;/tmp/ghc-6.8.2/utils/ghc-pkg/ghc-pkg.bin&#39; &#39;/home/nik/local/ghc-6.8.2/lib/ghc-6.8.2/package.conf&#39; &#39;/home/nik/local/ghc-6.8.2&#39; &#39;/home/nik/local/ghc-6.8.2&#39; &#39;/home/nik/local/ghc-6.8.2/bin&#39; &#39;/home/nik/local/ghc-6.8.2/lib/ghc-6.8.2/lib&#39; &#39;/home/nik/local/ghc-6.8.2/lib/ghc-6.8.2/lib&#39; &#39;/home/nik/local/ghc-6.8.2/share/ghc-6.8.2&#39; &#39;/home/nik/local/ghc-6.8.2/share/doc/ghc/libraries/$pkg&#39; &#39;/home/nik/local/ghc-6.8.2/share/doc/ghc/libraries/$pkg&#39; &#39;/home/nik/local/ghc-6.8.2/share/doc/ghc/libraries/$pkg&#39; ; \<br>
fi<br>Installing: /home/nik/local/ghc-6.8.2/lib/ghc-6.8.2/lib/base-3.0.1.0<br>gmake[1]: *** [install.library.base] Error 127<br>gmake[1]: Leaving directory `/tmp/ghc-6.8.2/libraries&#39;<br>gmake: *** [install] Error 2<br>
<br>--------------------------------------------------------------------------------------------------------------------------------------<br><br>Am I missing something?<br>Any help is very much appreciated!<br><br>Regards<br>
Nik<br>