Thanks for the feedback.<br><br>I guess the following part is the problematic part: (But I&#39;ve no idea how to resolve it)<br><br>Creating dist/build (and its parents)<br>Creating dist/build/autogen (and its parents)<br>
Preprocessing library zlib-0.5.2.0...<br>Creating dist/build/Codec/Compression/Zlib (and its parents)<br>/usr/bin/hsc2hs --cc=/usr/bin/gcc --ld=/usr/bin/gcc --cflag=-D__GLASGOW_HASKELL__=610 --lflag=-lz --cflag=-I/Users/ozgurakgun/.cabal/lib/bytestring-0.9.1.5/ghc-6.10.4/include --cflag=-I/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/base-4.1.0.0/include --cflag=-I/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/include --lflag=-L/Users/ozgurakgun/.cabal/lib/bytestring-0.9.1.5/ghc-6.10.4 --lflag=-L/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/base-3.0.3.1 --lflag=-L/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/syb-0.1.0.1 --lflag=-L/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/base-4.1.0.0 --lflag=-L/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/integer-0.1.0.1 --lflag=-L/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/ghc-prim-0.1.0.0 --lflag=-L/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4 --lflag=-lm --lflag=-lffi --lflag=-lgmp --lflag=-ldl <u>-o dist/build/Codec/Compression/Zlib/Stream.hs Codec/Compression/Zlib/Stream.hsc</u><br>
Only one output file may be specified<br>cabal: Error: some packages failed to install:<br>zlib-0.5.2.0 failed during the building phase. The exception was:<br>exit: ExitFailure 1<br><br><br><div class="gmail_quote">2009/12/19 Duncan Coutts <span dir="ltr">&lt;<a href="mailto:duncan.coutts@googlemail.com">duncan.coutts@googlemail.com</a>&gt;</span><br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div class="im">On Fri, 2009-12-18 at 23:01 +0000, Ozgur Akgun wrote:<br>
&gt; Hi,<br>
&gt;<br>
&gt; When I run cabal install zlib or cabal upgrade zlib I get the<br>
&gt; following error:<br>
&gt;<br>
&gt; Resolving dependencies...<br>
&gt; Configuring zlib-0.5.2.0...<br>
&gt; Preprocessing library zlib-0.5.2.0...<br>
&gt; Only one output file may be specified<br>
<br>
</div>We&#39;ll need more details here. Try running with -v2 or -v3. It should say<br>
what command it&#39;s running.<br>
<font color="#888888"><br>
Duncan<br>
<br>
</font></blockquote></div><br><br clear="all"><br>-- <br>Ozgur Akgun<br>