<div dir="ltr">I think you need to run &quot;cabal update&quot;<br><br><div class="gmail_quote">On Thu, Dec 31, 2009 at 8:54 AM, Edward Z. Yang <span dir="ltr">&lt;<a href="mailto:ezyang@mit.edu">ezyang@mit.edu</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">Excerpts from Michael Snoyman&#39;s message of Thu Dec 31 00:43:52 -0500 2009:<br>
<div class="im">&gt; What version of the packages are you using? Can you give the output of:<br>
&gt;<br>
&gt; ghc-pkg list|grep failure<br>
<br>
</div>Sure thing:<br>
<br>
    (control-monad-failure-0.4), (control-monad-failure-0.5.0),<br>
    control-monad-failure-mtl-0.5.0, cpphs-1.8, cpphs-1.9,<br>
    failure-0.0.0.1, happstack-0.3.2, happstack-data-0.3.3<br>
<br>
Additionally:<br>
<br>
ezyang@javelin:~$ cabal upgrade failure<br>
Resolving dependencies...<br>
No packages to be installed. All the requested packages are already installed.<br>
If you want to reinstall anyway then use the --reinstall flag.<br>
<br>
Cheers,<br>
<font color="#888888">Edward<br>
</font></blockquote></div><br></div>