<br><br><div class="gmail_quote">On Fri, Jan 29, 2010 at 1:09 AM, zaxis <span dir="ltr">&lt;<a href="mailto:z_axis@163.com">z_axis@163.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<br>
`cabal install regex-compat` fixes my problem.  thanks!<br></blockquote><div><br>For what it&#39;s worth, according to the documentation the &quot;-compat&quot; package is for easing a transition in the api (which has now been completed).  You may want to &quot;upgrade&quot; to a different package now, for instance regex-posix (which I&#39;ve found to be in a nice spot between portability and performance).<br>
<br>Jason<br></div></div><br>