<html><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">As a work around install happstack-data like this:<div><br></div><div><meta charset="utf-8"><span class="Apple-style-span" style="font-family: arial, sans-serif; font-size: 12px; "><p>cabal install -O0&nbsp;<b style="color: black; background-color: rgb(255, 255, 102); ">happstack-data</b>&nbsp;</p></span></div><div><br></div><div>More details at the end of this thread:</div><div><br></div><div><a href="http://groups.google.com/group/happs/browse_thread/thread/c66c74294d8eabf/a4de5e67853925e0?lnk=gst&amp;q=happstack-data#a4de5e67853925e0">http://groups.google.com/group/happs/browse_thread/thread/c66c74294d8eabf/a4de5e67853925e0?lnk=gst&amp;q=happstack-data#a4de5e67853925e0</a></div><div><div><br></div><div>I am using GHC 6.13, and I believe this problem has been resolved. Not sure what the best work around is in the meantime though. I guess I should at least update the download page to mention it..</div><div><br></div><div>- jeremy</div><div><br><div><div>On Feb 11, 2010, at 4:19 PM, Станислав Черничкин wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"> <div bgcolor="#ffffff" text="#000000"> I was unable to install happstack-data-0.4.1 on windows with GHC 6.12.1. Here the log:<br> <br> <small><small><tt>Resolving dependencies...<br> Configuring happstack-data-0.4.1...<br> Preprocessing library happstack-data-0.4.1...<br> Preprocessing executables for happstack-data-0.4.1...<br> Building happstack-data-0.4.1...<br> <br> src\Happstack\Data\GOps.hs:54:0:<br> &nbsp;&nbsp;&nbsp;&nbsp; warning: no newline at end of file<br> <br> src\Happstack\Data\SerializeTH.hs:88:0:<br> &nbsp;&nbsp;&nbsp;&nbsp; warning: no newline at end of file<br> [ 1 of 16] Compiling Happstack.Data.GOps ( src\Happstack\Data\GOps.hs, dist\buil<br> d\Happstack\Data\GOps.o )<br> <br> src\Happstack\Data\Serialize.hs:1:85:<br> &nbsp;&nbsp;&nbsp; Warning: -XPatternSignatures is deprecated: use -XScopedTypeVariables or pra<br> gma {-# LANGUAGE ScopedTypeVariables #-} instead<br> <br> src\Happstack\Data\Xml\Base.hs:6:13:<br> &nbsp;&nbsp;&nbsp; Warning: -XPatternSignatures is deprecated: use -XScopedTypeVariables or pra<br> gma {-# LANGUAGE ScopedTypeVariables #-} instead<br> [ 2 of 16] Compiling Happstack.Data.Normalize ( src\Happstack\Data\Normalize.hs,<br> &nbsp;dist\build\Happstack\Data\Normalize.o )<br> [ 3 of 16] Compiling Happstack.Data.Migrate ( src\Happstack\Data\Migrate.hs, dis<br> t\build\Happstack\Data\Migrate.o )<br> [ 4 of 16] Compiling Happstack.Data.Default ( src\Happstack\Data\Default.hs, dis<br> t\build\Happstack\Data\Default.o )<br> [ 5 of 16] Compiling Happstack.Data.DeriveAll ( src\Happstack\Data\DeriveAll.hs,<br> &nbsp;dist\build\Happstack\Data\DeriveAll.o )<br> [ 6 of 16] Compiling Happstack.Data.Default.Generic ( src\Happstack\Data\Default<br> \Generic.hs, dist\build\Happstack\Data\Default\Generic.o )<br> [ 7 of 16] Compiling Happstack.Data.Xml.Base ( src\Happstack\Data\Xml\Base.hs, d<br> ist\build\Happstack\Data\Xml\Base.o )<br> Loading package ghc-prim ... linking ... done.<br> Loading package integer-gmp ... linking ... done.<br> Loading package base ... linking ... done.<br> Loading package array-0.3.0.0 ... linking ... done.<br> Loading package bytestring-0.9.1.5 ... linking ... done.<br> Loading package containers-0.3.0.0 ... linking ... done.<br> Loading package pretty-1.0.1.1 ... linking ... done.<br> Loading package template-haskell ... linking ... done.<br> Loading package syb-with-class-0.6.1 ... linking ... done.<br> Loading package HUnit-1.2.2.1 ... linking ... done.<br> Loading package syb-0.1.0.2 ... linking ... done.<br> Loading package base-3.0.3.2 ... linking ... done.<br> Loading package Win32-2.2.0.1 ... linking ... done.<br> Loading package old-locale-1.0.0.2 ... linking ... done.<br> Loading package time-1.1.4 ... linking ... done.<br> Loading package random-1.0.0.2 ... linking ... done.<br> Loading package QuickCheck-1.2.0.0 ... linking ... done.<br> Loading package extensible-exceptions-0.1.1.1 ... linking ... done.<br> Loading package mtl-1.1.0.2 ... linking ... done.<br> Loading package old-time-1.0.0.3 ... linking ... done.<br> Loading package parsec-2.1.0.1 ... linking ... done.<br> Loading package hsemail-1.3 ... linking ... done.<br> Loading package network-2.2.1.7 ... linking ... done.<br> Loading package SMTPClient-1.0.1 ... linking ... done.<br> Loading package filepath-1.1.0.3 ... linking ... done.<br> Loading package directory-1.0.1.0 ... linking ... done.<br> Loading package process-1.0.1.2 ... linking ... done.<br> Loading package hslogger-1.0.7 ... linking ... done.<br> Loading package deepseq-1.1.0.0 ... linking ... done.<br> Loading package parallel-2.2.0.1 ... linking ... done.<br> Loading package strict-concurrency-0.2.2 ... linking ... done.<br> Loading package unix-compat-0.1.2.1 ... linking ... done.<br> Loading package happstack-util-0.4.1 ... linking ... done.<br> Loading package binary-0.5.0.2 ... linking ... done.<br> Loading package haskell98 ... linking ... done.<br> Loading package HaXml-1.13.3 ... linking ... done.<br> Loading package ffi-1.0 ... linking ... done.<br> ghc.exe: dist\build\Happstack\Data\Default.o: unknown symbol `_sybzmwithzmclassz<br> m0zi6zi1_DataziGenericsziSYBziWithClassziInstances_constrZMacbsZN_closure'<br> <br> cabal: Error: some packages failed to install:<br> happstack-data-0.4.1 failed during the building phase. The exception was:<br> ExitFailure 1</tt></small></small><br> <br> I can create more detailed log if you need.<br> </div>  _______________________________________________<br>Haskell-Cafe mailing list<br><a href="mailto:Haskell-Cafe@haskell.org">Haskell-Cafe@haskell.org</a><br>http://www.haskell.org/mailman/listinfo/haskell-cafe<br></blockquote></div><br></div></div></body></html>