Hi,<br><br>I am trying to install Criterion package, but I keep getting an error and I can&#39;t figure it out why it is like this !!<br><br>mozhgan@Mozhgan-KCh:~$ cabal install Criterion<br>Resolving dependencies...<br>Configuring vector-algorithms-0.3...<br>
Preprocessing library vector-algorithms-0.3...<br>Building vector-algorithms-0.3...<br>[1 of 9] Compiling Data.Vector.Algorithms.Common ( Data/Vector/Algorithms/Common.hs, dist/build/Data/Vector/Algorithms/Common.o )<br>[2 of 9] Compiling Data.Vector.Algorithms.Search ( Data/Vector/Algorithms/Search.hs, dist/build/Data/Vector/Algorithms/Search.o )<br>
[3 of 9] Compiling Data.Vector.Algorithms.Radix ( Data/Vector/Algorithms/Radix.hs, dist/build/Data/Vector/Algorithms/Radix.o )<br>[4 of 9] Compiling Data.Vector.Algorithms.Optimal ( Data/Vector/Algorithms/Optimal.hs, dist/build/Data/Vector/Algorithms/Optimal.o )<br>
[5 of 9] Compiling Data.Vector.Algorithms.Insertion ( Data/Vector/Algorithms/Insertion.hs, dist/build/Data/Vector/Algorithms/Insertion.o )<br>[6 of 9] Compiling Data.Vector.Algorithms.Merge ( Data/Vector/Algorithms/Merge.hs, dist/build/Data/Vector/Algorithms/Merge.o )<br>
[7 of 9] Compiling Data.Vector.Algorithms.TriHeap ( Data/Vector/Algorithms/TriHeap.hs, dist/build/Data/Vector/Algorithms/TriHeap.o )<br>[8 of 9] Compiling Data.Vector.Algorithms.Intro ( Data/Vector/Algorithms/Intro.hs, dist/build/Data/Vector/Algorithms/Intro.o )<br>
ghc: panic! (the &#39;impossible&#39; happened)<br>  (GHC version 6.10.4 for i386-unknown-linux):<br>    idInfo co{v a9WB} [tv]<br><br>Please report this as a GHC bug:  <a href="http://www.haskell.org/ghc/reportabug">http://www.haskell.org/ghc/reportabug</a><br>
<br>cabal: Error: some packages failed to install:<br>criterion-0.5.0.0 depends on vector-algorithms-0.3 which failed to install.<br>statistics-0.5.1.0 depends on vector-algorithms-0.3 which failed to install.<br>vector-algorithms-0.3 failed during the building phase. The exception was:<br>
exit: ExitFailure 1<br><br>I tried to install Statistics and vector-algorithms package separately before installing the Criterion package itself .. but it wasn&#39;t successful. <br><br>Thanks,<br><br>Mozhgan<br>