<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">

<head>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii">
<meta name=Generator content="Microsoft Word 12 (filtered medium)">
<style>
<!--
 /* Font Definitions */
 @font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
@font-face
        {font-family:Consolas;
        panose-1:2 11 6 9 2 2 4 3 2 4;}
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
p.MsoPlainText, li.MsoPlainText, div.MsoPlainText
        {mso-style-priority:99;
        mso-style-link:"Plain Text Char";
        margin:0in;
        margin-bottom:.0001pt;
        font-size:10.5pt;
        font-family:Consolas;}
span.PlainTextChar
        {mso-style-name:"Plain Text Char";
        mso-style-priority:99;
        mso-style-link:"Plain Text";
        font-family:Consolas;}
span.EmailStyle19
        {mso-style-type:personal;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
span.EmailStyle20
        {mso-style-type:personal-reply;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page Section1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.Section1
        {page:Section1;}
-->
</style>
<!--[if gte mso 9]><xml>
 <o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
 <o:shapelayout v:ext="edit">
  <o:idmap v:ext="edit" data="1" />
 </o:shapelayout></xml><![endif]-->
</head>

<body lang=EN-US link=blue vlink=purple>

<div class=Section1>

<p class=MsoNormal style='margin-left:.5in'><b><span style='color:#1F497D'>&quot;base-3.0.3.2-b2241f4c659fe250ebb821a4173f40c9&quot;
doesn't exist (use --force to override)<o:p></o:p></span></b></p>

<p class=MsoNormal><span style='color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal><span style='color:#1F497D'>Having installed GHC 6.12.2, I
am hitting these problems with every package I tried to install:<o:p></o:p></span></p>

<p class=MsoNormal><span style='color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>C:\Users\Ralph&gt;cabal
install parsec<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>Resolving
dependencies...<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>Configuring
parsec-2.1.0.1...<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>Preprocessing
library parsec-2.1.0.1...<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>Building
parsec-2.1.0.1...<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>[ 1 of
10] Compiling Text.ParserCombinators.Parsec.Pos ( Text\ParserCombinators\<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>Parsec\Pos.hs,
dist\build\Text\ParserCombinators\Parsec\Pos.o )<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>[snip]<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>[ 9 of
10] Compiling Text.ParserCombinators.Parsec.Perm ( Text\ParserCombinators<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>\Parsec\Perm.hs,
dist\build\Text\ParserCombinators\Parsec\Perm.o )<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>Text\ParserCombinators\Parsec\Perm.hs:1:0:<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>&nbsp;&nbsp;&nbsp;
Warning: Module `Prelude' is deprecated:<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
You are using the old package `base' version 3.x.<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
Future GHC versions will not support base version 3.x. You<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
should update your code to use the new base version 4.x.<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>[10 of
10] Compiling Text.ParserCombinators.Parsec.Language ( Text\ParserCombina<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>tors\Parsec\Language.hs,
dist\build\Text\ParserCombinators\Parsec\Language.o )<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>Text\ParserCombinators\Parsec\Language.hs:1:0:<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>&nbsp;&nbsp;&nbsp;
Warning: Module `Prelude' is deprecated:<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
You are using the old package `base' version 3.x.<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
Future GHC versions will not support base version 3.x. You<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
should update your code to use the new base version 4.x.<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>Registering
parsec-2.1.0.1...<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>Installing
library in<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='color:#1F497D'>C:\Users\Ralph\AppData\Roaming\cabal\parsec-2.1.0.1\ghc-6.12.2<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><b><span style='color:#1F497D'>Registering
parsec-2.1.0.1...<o:p></o:p></span></b></p>

<p class=MsoNormal style='margin-left:.5in'><b><span style='color:#1F497D'>cabal:
parsec-2.1.0.1: dependency<o:p></o:p></span></b></p>

<p class=MsoNormal style='margin-left:.5in'><b><span style='color:#1F497D'>&quot;base-3.0.3.2-b2241f4c659fe250ebb821a4173f40c9&quot;
doesn't exist (use --force to<o:p></o:p></span></b></p>

<p class=MsoNormal style='margin-left:.5in'><b><span style='color:#1F497D'>override)<o:p></o:p></span></b></p>

<p class=MsoNormal style='margin-left:.5in'><b><span style='color:#1F497D'>cabal:
Error: some packages failed to install:<o:p></o:p></span></b></p>

<p class=MsoNormal style='margin-left:.5in'><b><span style='color:#1F497D'>parsec-2.1.0.1
failed during the final install step. The exception was:<o:p></o:p></span></b></p>

<p class=MsoNormal style='margin-left:.5in'><b><span style='color:#1F497D'>exit:
ExitFailure 1<o:p></o:p></span></b></p>

<p class=MsoNormal><b><span style='color:#1F497D'><o:p>&nbsp;</o:p></span></b></p>

<p class=MsoNormal><span style='color:#1F497D'>I wonder what to do next?<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><b><span style='color:#1F497D'><o:p>&nbsp;</o:p></span></b></p>

<p class=MsoNormal><span style='color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<div>

<div style='border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in'>

<p class=MsoNormal><b><span style='font-size:10.0pt;font-family:"Tahoma","sans-serif"'>From:</span></b><span
style='font-size:10.0pt;font-family:"Tahoma","sans-serif"'> Ralph Hodgson
[mailto:rhodgson@topquadrant.com] <br>
<b>Sent:</b> Tuesday, June 01, 2010 11:19 AM<br>
<b>To:</b> rhodgson@topquadrant.com; 'Don Stewart'<br>
<b>Cc:</b> 'Henning Thielemann'; haskell-cafe@haskell.org<br>
<b>Subject:</b> RE: [Haskell-cafe] Installing Curl on Windows 7 - no longer a
permissions problem - due to dependency conflicts<o:p></o:p></span></p>

</div>

</div>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'>Permissions issue was straight-forward to resolve.<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'>Yesterday I tracked this down to a conflict with versions of
bytestring.<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'>ghc.6.10.4 needs bytestring-0.9.1.4 <o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='font-size:12.0pt;
font-family:"Arial","sans-serif";color:#1F497D'>ghc-pkg: unregistering
bytestring-0.9.1.4 would break the following packages: ha<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='font-size:12.0pt;
font-family:"Arial","sans-serif";color:#1F497D'>ddock-2.4.2 ghc-6.10.4
Win32-2.2.0.0 regex-base-0.72.0.2 regex-posix-0.72.0.3 re<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='font-size:12.0pt;
font-family:"Arial","sans-serif";color:#1F497D'>gex-compat-0.71.0.1
zlib-0.5.0.0 HTTP-4000.0.6 cgi-3001.1.7.1 curl-1.3.5 QuickCh<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='font-size:12.0pt;
font-family:"Arial","sans-serif";color:#1F497D'>eck-2.1.0.3 tagsoup-0.9
feed-0.3.7 tagsoup-0.10 utf8-string-0.3.6 xml-1.3.7 (use<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='font-size:12.0pt;
font-family:"Arial","sans-serif";color:#1F497D'>&nbsp;--force to override)<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='font-size:12.0pt;
font-family:"Arial","sans-serif";color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'>other libraries need bytestring-09.1.6<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='font-size:12.0pt;
font-family:"Arial","sans-serif";color:#1F497D'>ghc-pkg: unregistering
bytestring-0.9.1.6 would break the following packages: Wi<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='font-size:12.0pt;
font-family:"Arial","sans-serif";color:#1F497D'>n32-2.2.0.0 Win32-2.2.0.2
HTTP-4000.0.9 (use --force to override)<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='font-size:12.0pt;
font-family:"Arial","sans-serif";color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'>Yesterday I could not &nbsp;access haskell.org &nbsp;to see if I
can install a newer version of GHC - network or server is done.<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'>Today I am upgrading everything to ghc-6.12.2<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'>There must be a tool somewhere that can assess potential
conflicts :<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='font-size:12.0pt;
font-family:"Arial","sans-serif";color:#1F497D'>A needs B (&gt;2)<o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='font-size:12.0pt;
font-family:"Arial","sans-serif";color:#1F497D'>A needs C (&gt;1) but <o:p></o:p></span></p>

<p class=MsoNormal style='margin-left:.5in'><span style='font-size:12.0pt;
font-family:"Arial","sans-serif";color:#1F497D'>C needs B (&lt;2)<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal><span style='font-size:12.0pt;font-family:"Arial","sans-serif";
color:#1F497D'>I will look once I get passed these install issues<o:p></o:p></span></p>

<p class=MsoNormal><span style='color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<div>

<div style='border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in'>

<p class=MsoNormal><b><span style='font-size:10.0pt;font-family:"Tahoma","sans-serif"'>From:</span></b><span
style='font-size:10.0pt;font-family:"Tahoma","sans-serif"'>
haskell-cafe-bounces@haskell.org [mailto:haskell-cafe-bounces@haskell.org] <b>On
Behalf Of </b>Ralph Hodgson<br>
<b>Sent:</b> Monday, May 31, 2010 2:51 PM<br>
<b>To:</b> 'Don Stewart'<br>
<b>Cc:</b> 'Henning Thielemann'; haskell-cafe@haskell.org<br>
<b>Subject:</b> [Haskell-cafe] Installing Curl on Windows 7 - permissions
problem<o:p></o:p></span></p>

</div>

</div>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>Don,<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>More angst with Windows 7 permissions. &nbsp;I hope this is
a simple thing for you or someone else to help me with.<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>I have successfully installed other packages into my
private cabal area. &nbsp;&nbsp;<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>When it came to the Haskell curl package, I got
permission errors.<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>Just to prove that things go to the right places, here is
a successful run with the Parseargs Package.<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>C:\Users\Ralph&gt;cabal install
parseargs<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Resolving dependencies...<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Downloading parseargs-0.1.3...<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Configuring parseargs-0.1.3...<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Preprocessing library
parseargs-0.1.3...<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Preprocessing executables for
parseargs-0.1.3...<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Building parseargs-0.1.3...<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>[1 of 1] Compiling
System.Console.ParseArgs ( System\Console\ParseArgs.hs, dist\<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>build\System\Console\ParseArgs.o
)<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Registering parseargs-0.1.3...<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>[1 of 2] Compiling
System.Console.ParseArgs ( System\Console\ParseArgs.hs, dist\<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>build\parseargs-example\parseargs-example-tmp\System\Console\ParseArgs.o
)<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>[2 of 2] Compiling
Main&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; (
parseargs-example.hs, dist\build\parseargs<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>-example\parseargs-example-tmp\Main.o
)<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Linking
dist\build\parseargs-example\parseargs-example.exe ...<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Installing library in<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>C:\Users\Ralph\AppData\Roaming\cabal\parseargs-0.1.3\ghc-6.10.4<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Installing executable(s) in
C:\Users\Ralph\AppData\Roaming\cabal\bin<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Registering parseargs-0.1.3...<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>Parseargs installed fine and the package list shows it in
my cabal directory.<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>C:\Users\Ralph&gt;ghc-pkg list<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>C:/Program Files (x86)/Haskell
Platform/2009.2.0.2\package.conf:<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp;
Cabal-1.6.0.3, GLUT-2.1.1.2, HTTP-4000.0.6, HUnit-1.2.0.3,<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp;
OpenGL-2.2.1.1, QuickCheck-1.2.0.0, Win32-2.2.0.0, array-0.2.0.0,<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp; base-3.0.3.1,
base-4.1.0.0, bytestring-0.9.1.4, cgi-3001.1.7.1,<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp;
containers-0.2.0.1, directory-1.0.0.3, (dph-base-0.3),<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp;
(dph-par-0.3), (dph-prim-interface-0.3), (dph-prim-par-0.3),<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp; (dph-prim-seq-0.3),
(dph-seq-0.3), extensible-exceptions-0.1.1.0,<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp; fgl-5.4.2.2,
filepath-1.1.0.2, (ghc-6.10.4), ghc-prim-0.1.0.0,<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp;
haddock-2.4.2, haskell-src-1.0.1.3, haskell98-1.0.1.0, hpc-0.5.0.3,<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp; html-1.0.1.2,
integer-0.1.0.1, mtl-1.1.0.2, network-2.2.1.4,<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp;
old-locale-1.0.0.1, old-time-1.0.0.2, packedstring-0.1.0.1,<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp;
parallel-1.1.0.1, parsec-2.1.0.1, pretty-1.0.1.0, process-1.0.1.1,<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp;
random-1.0.0.1, regex-base-0.72.0.2, regex-compat-0.71.0.1,<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp;
regex-posix-0.72.0.3, rts-1.0, stm-2.1.1.2, syb-0.1.0.1,<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp;
template-haskell-2.3.0.1, time-1.1.2.4, xhtml-3000.2.0.1,<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp; zlib-0.5.0.0<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>C:\Users\Ralph\AppData\Roaming\ghc\i386-mingw32-6.10.4\package.conf:<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp;
Cabal-1.8.0.4, ListZipper-1.1.1.0, QuickCheck-2.1.0.3,<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>&nbsp;&nbsp;&nbsp;
bytestring-0.9.1.6, deepseq-1.1.0.0, parseargs-0.1.3, tagsoup-0.9<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>C:\Users\Ralph&gt;<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>Now for curl. <o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>I installed Mingw32 (following the advice at <a
href="http://old.nabble.com/cURL-under-Windows-again-td21789068.html#a21789068">http://old.nabble.com/cURL-under-Windows-again-td21789068.html#a21789068</a>)<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>This is what happened when I went to my windows shell:<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>C:\Users\Ralph\AppData\Roaming\cabal\curl-1.3.5&gt;runhaskell
setup build<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Preprocessing library
curl-1.3.5...<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Building curl-1.3.5...<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>Registering curl-1.3.5...<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText style='margin-left:.5in'>C:\Users\Ralph\AppData\Roaming\cabal\curl-1.3.5&gt;runhaskell
setup install<o:p></o:p></p>

<p class=MsoPlainText style='margin-left:.5in'><b>setup: permission denied<o:p></o:p></b></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>I am wondering if the curl package is trying to put
things in system folders?<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>Help much appreciated - tight deadlines<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>Ralph<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>-----Original Message-----<br>
From: haskell-cafe-bounces@haskell.org
[mailto:haskell-cafe-bounces@haskell.org] On Behalf Of Don Stewart<br>
Sent: Wednesday, May 19, 2010 1:37 PM<br>
To: Henning Thielemann<br>
Cc: haskell-cafe@haskell.org<br>
Subject: Re: [Haskell-cafe] TagSoup 0.9<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>schlepptop:<o:p></o:p></p>

<p class=MsoPlainText>&gt; Don Stewart schrieb:<o:p></o:p></p>

<p class=MsoPlainText>&gt; &gt; Or use things from the download-curl package,
which provides a nice<o:p></o:p></p>

<p class=MsoPlainText>&gt; &gt; openURL function.<o:p></o:p></p>

<p class=MsoPlainText>&gt; <o:p></o:p></p>

<p class=MsoPlainText>&gt; The openURL function from TagSoup is lazy, which the
proposed<o:p></o:p></p>

<p class=MsoPlainText>&gt; replacement 'getResponseBody =&lt;&lt; simpleHTTP
(getRequest x)' is not. Is<o:p></o:p></p>

<p class=MsoPlainText>&gt; the openURL function from download-curl lazy?<o:p></o:p></p>

<p class=MsoPlainText>&gt; <o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>Yes, see:<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>&nbsp;&nbsp;&nbsp; Network.Curl.Download.Lazy.openLazyURI<o:p></o:p></p>

<p class=MsoPlainText><o:p>&nbsp;</o:p></p>

<p class=MsoPlainText>though I think it is possible that I strictified the
code. Have a play<o:p></o:p></p>

<p class=MsoPlainText>around with it if it doesn't meet your needs -- should be
/trivial/ to<o:p></o:p></p>

<p class=MsoPlainText>ensure it is chunk-wise lazy.<o:p></o:p></p>

<p class=MsoPlainText>_______________________________________________<o:p></o:p></p>

<p class=MsoPlainText>Haskell-Cafe mailing list<o:p></o:p></p>

<p class=MsoPlainText>Haskell-Cafe@haskell.org<o:p></o:p></p>

<p class=MsoPlainText>http://www.haskell.org/mailman/listinfo/haskell-cafe<o:p></o:p></p>

</div>

</body>

</html>