<br>You might try pulling downloading the package (&#39;cabal fetch org&#39;  will do this) and changing the base dependency (to &gt;= 4.1) in the orc.cabal file and then build it manually (cabal configure &amp;&amp; cabal build &amp;&amp; cabal install  (while in the same directory as the .cabal file)) and see what happens.<br>
<br>I don&#39;t see any obvious reasons why it would need a version greater than 6.10, so it might just be an over restrictive dependency rule, but I might be missing something.<br><br>- Job<br><br><div class="gmail_quote">
On Wed, Jul 28, 2010 at 10:49 PM, Eitan Goldshtrom <span dir="ltr">&lt;<a href="mailto:thesourceofx@gmail.com">thesourceofx@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Ah! That clears that up a lot. I read the wiki page but something just didn&#39;t make full sense about it until you used the word &quot;prevent&quot;. I understand that the computer doesn&#39;t actually prevent other threads from running -- that would defeat the purpose of the concurrency -- but it helped clear it up. Perhaps you guys could help me with Cabal now though? I&#39;m trying to install Orc but it wants base&gt;=4.2 and &lt;=4.3 and I have 4.1 after installing the latest release of GHC. Cabal won&#39;t upgrade the base. It complains about a dependency to &quot;integer-simple&quot;. Anyone know what that&#39;s about?<div>
<div></div><div class="h5"><br>
<br>
-Eitan<br>
_______________________________________________<br>
Haskell-Cafe mailing list<br>
<a href="mailto:Haskell-Cafe@haskell.org" target="_blank">Haskell-Cafe@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/haskell-cafe" target="_blank">http://www.haskell.org/mailman/listinfo/haskell-cafe</a><br>
</div></div></blockquote></div><br>