Yes, EclipseFP is alive, and I&#39;m the maintainer. Yes, there are sometimes issues with installing scion due to the numerous dependencies. No, don&#39;t give up!!<div><br></div><div>You don&#39;t need to build scion yourself, usually. The Java plugins include the scion sources and build it internally, setting the proper Cabal flags. If you want to build scion yourself, you need to specify that you use Cabal 1.8: cabal install -fcabal_1_8 should do the trick.</div>
<div><br></div><div>There are also forums on sourceforge that I keep an eye on so you can post questions there too!</div><div><br></div><div>Hope it helps!</div><div><br></div><div>JP<br><br><div class="gmail_quote">2010/11/27 Dušan Kolář <span dir="ltr">&lt;<a href="mailto:kolar@fit.vutbr.cz">kolar@fit.vutbr.cz</a>&gt;</span><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">Hello,<br>
<br>
  I tried to install EclipseFP using instructions on <a href="http://eclipsefp.sourceforge.net/" target="_blank">http://eclipsefp.sourceforge.net/</a>, nevertheless, without any success - after downloading scion I cannot build it<br>

<br>
&gt; cabal install<br>
Resolving dependencies...<br>
cabal: dependencies conflict: ghc-6.12.3 requires Cabal ==1.8.0.6 however<br>
Cabal-1.8.0.6 was excluded because scion-0.1.0.6 requires Cabal ==1.6.*<br>
<br>
Running Setup.hs through runhaskell seems not to work as well:<br>
&gt; runhaskell Setup.hs configure<br>
Configuring scion-0.1.0.6...<br>
Setup.hs: At least the following dependencies are missing:<br>
AttoJson &gt;=0.5.2,<br>
binary ==0.5.*,<br>
derive -any,<br>
ghc-paths ==0.1.*,<br>
ghc-syb -any,<br>
ghc-syb-utils -any,<br>
hslogger ==1.0.*,<br>
list-tries -any,<br>
multiset &gt;=0.1 &amp;&amp; &lt;0.3,<br>
uniplate -any<br>
<br>
Even if, for instance:<br>
&gt; cabal info binary<br>
* binary           (library)<br>
    Synopsis:      Binary serialisation for Haskell values using lazy<br>
                   ByteStrings<br>
    Latest version available: 0.5.0.2<br>
    Latest version installed: 0.5.0.2<br>
<br>
Is there any chance to make it install or should I give up?<br>
<br>
Dusan<br>
<br>
_______________________________________________<br>
Haskell-Cafe mailing list<br>
<a href="mailto:Haskell-Cafe@haskell.org" target="_blank">Haskell-Cafe@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/haskell-cafe" target="_blank">http://www.haskell.org/mailman/listinfo/haskell-cafe</a><br>
</blockquote></div><br><br clear="all"><br>-- <br>JP Moresmau<br><a href="http://jpmoresmau.blogspot.com/">http://jpmoresmau.blogspot.com/</a><br>
</div>