<div>----------------------------------------------------------------------------------------------</div><div>collect2: ld terminated with signal 15 // PROBLEM SOLVED</div><div>----------------------------------------------------------------------------------------------</div>

<div><br></div>*** HASKELL PLATFORM<br><font class="Apple-style-span" face="&#39;courier new&#39;, monospace">Building <br>&quot;/usr/haskell-platform-2010.2.0.0/bin/ghc&quot; &quot;--make&quot; &quot;Setup&quot; &quot;-o&quot; &quot;Setup&quot; <br>

&quot;-package&quot; &quot;Cabal-1.8.0.6&quot; <br>Linking Setup ... <br>collect2: ld terminated with signal 15 [Terminated] <br><br>Error: <br>Compiling the Setup script failed <br>make: *** [build.stamp] Error 2 </font><br>

<br><br>*** CABAL<br><div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace">[1 of 1] Compiling Main             ( Setup.lhs, Setup.o )</font><br><font class="Apple-style-span" face="&#39;courier new&#39;, monospace">Linking Setup ...</font><br>

<font class="Apple-style-span" face="&#39;courier new&#39;, monospace">collect2: ld terminated with signal 15 [Terminated]</font><br><font class="Apple-style-span" face="&#39;courier new&#39;, monospace">Error during cabal-install bootstrap:</font><br>

<font class="Apple-style-span" face="&#39;courier new&#39;, monospace">Compiling the Setup script failed</font><div><br></div><div><br></div><div>******************************************************************************</div>

<div>UPDATE // collect2: ld problem solved : caused by lack of RAM</div><div>******************************************************************************</div><div>It seems like the problems described above was caused by the system running out of memory. Initially I had only 512 MB of RAM on my server, but after an upgrade to 2 GB RAM the installation went fine without any problems at all. I realised this running &quot;top&quot; and seeing all the memory being consumed by GHC.</div>

<div><br></div><div>I ran into a couple of new problems trying to install the Platform, so I have not fully succeeded yet, but I am a lot closer...</div><div><br></div><div><div>(Note: I also installed GCC 4.4 (as mentioned by Mr Peterson) before I retried installing Cabal and the Haskell Platform , but I do not think that affected the build / compile process at all, since GHC and not GCC is used here. And GCC 4.4 is also installed next to 4.1 that presumably would be used by default (or am I wrong about this?))</div>

</div><div><br></div><div><br>[k]</div></div>