Package Text.XML.HXT.Arrow existed only in 8.5.2 version of hxt:<br><a href="http://hackage.haskell.org/packages/archive/hxt/8.5.2/doc/html/Text-XML-HXT-Arrow.html">http://hackage.haskell.org/packages/archive/hxt/8.5.2/doc/html/Text-XML-HXT-Arrow.html</a><br>
<br>Yet trying to install with this version produce even more problems:<br> <br>~&gt;cabal --constraint=hxt==8.5.2 install hSimpleDB<br>Resolving dependencies...<br>cabal: cannot configure Crypto-4.2.3. It requires QuickCheck &gt;=2.4.0.1<br>
For the dependency on QuickCheck &gt;=2.4.0.1 there are these packages:<br>QuickCheck-2.4.0.1, QuickCheck-2.4.1 and QuickCheck-2.4.1.1. However none of<br>them are available.<br>QuickCheck-2.4.0.1 was excluded because tagsoup-0.8 requires QuickCheck<br>
==2.1.*<br>QuickCheck-2.4.1 was excluded because tagsoup-0.8 requires QuickCheck ==2.1.*<br>QuickCheck-2.4.1.1 was excluded because tagsoup-0.8 requires QuickCheck<br>==2.1.*<br><br><br><div class="gmail_quote">On Tue, Nov 8, 2011 at 2:43 PM, dokondr <span dir="ltr">&lt;<a href="mailto:dokondr@gmail.com">dokondr@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div><div></div><div class="h5"><br><br><div class="gmail_quote">On Tue, Nov 8, 2011 at 2:31 PM, Audun Skaugen <span dir="ltr">&lt;<a href="mailto:audunskaugen@gmail.com" target="_blank">audunskaugen@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div><div></div><div>Erik Hesselink wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
On Tue, Nov 8, 2011 at 12:16, Ivan Lazar Miljenovic<br>
&lt;<a href="mailto:ivan.miljenovic@gmail.com" target="_blank">ivan.miljenovic@gmail.com</a>&gt; wrote:<br>
  <br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
On 8 November 2011 22:10, Erik Hesselink &lt;<a href="mailto:hesselink@gmail.com" target="_blank">hesselink@gmail.com</a>&gt; wrote:<br>
    <br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
This is because hSimpleDB doesn&#39;t specify version ranges on its<br>
dependencies, when it should. Since hxt changed its module structure<br>
going from 9.0 to 9.1, hSimpleDB doesn&#39;t build against 9.0.<br>
<br>
You can try to build it by adding &#39;--constraint=hxt==9.0.\*&#39; after<br>
your cabal-install command. You can also ask the author to add version<br>
ranges to the package.<br>
      <br>
</blockquote>
Is the escape needed if you&#39;re using single quotes?<br>
    <br>
</blockquote>
<br>
I don&#39;t know. I always escape *s in shell commands to be sure the<br>
shell doesn&#39;t expand them, but in most of the cases, it probably works<br>
without them. It will likely even work without quotes and without the<br>
escape, unless you have files matching the pattern.<br>
  <br>
</blockquote></div></div>
The single quote doesn&#39;t expand anything, so you don&#39;t need to escape the *. Actually, this will result in the backslash also being passed to cabal, so I would be surprised if your command works at all.<br>
</blockquote></div><br><br clear="all"></div></div>No matter how you escape *, you get the same error:<div><div></div><div class="h5"><br><br>Preprocessing library hSimpleDB-0.3...<br>Building hSimpleDB-0.3...<br><br>src/Network/AWS/Authentication.hs:47:7:<br>
    Could not find module `Text.XML.HXT.Arrow&#39;:<br>
<br>
</div></div></blockquote></div><br><br clear="all"><br>