<div dir="ltr">On Mon, Jan 2, 2012 at 21:36, Victor Miller <span dir="ltr">&lt;<a href="mailto:victorsmiller@gmail.com">victorsmiller@gmail.com</a>&gt;</span> wrote:<br><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
&lt;command line&gt;: cannot satisfy -package-id mtl-2.0.1.0-5b7a9cce5565d8cc8721ba4f95becf1b<br>    (use -v for more information)<br><br>However, cabal list tells me:<br><br>* mtl<br>    Synopsis: Monad classes, using functional dependencies<br>
    Default available version: 2.0.1.0<br>
    Installed versions: 2.0.1.0<br>    License:  BSD3<br></blockquote><div><br></div><div>The right version, but possibly not the right ABI hash.  Also, it might be broken by some other dependency; try &quot;ghc-pkg list&quot; which should give you an idea about both issues.  ghc is regrettably not very good about saying *why* it &quot;cannot satisfy&quot; a package dependency.</div>
</div><div><br></div>-- <br>brandon s allbery                                      <a href="mailto:allbery.b@gmail.com" target="_blank">allbery.b@gmail.com</a><br>wandering unix systems administrator (available)     (412) 475-9364 vm/sms<br>
<br>
</div>