# uname -a<br>Linux &lt;&lt;hosename&gt;&gt; 2.6.32-220.2.1.el6.centos.plus.x86_64 #1 SMP Thu Dec 22 23:32:31 GMT 2011 x86_64 x86_64 x86_64 GNU/Linux<br><br><br># cat /proc/version<br>Linux version 2.6.32-220.2.1.el6.centos.plus.x86_64 (<a href="mailto:mockbuild@c6b18n3.bsys.dev.centos.org">mockbuild@c6b18n3.bsys.dev.centos.org</a>) (gcc version 4.4.6 20110731 (Red Hat 4.4.6-3) (GCC) ) #1 SMP Thu Dec 22 23:32:31 GMT 2011<br>
<br>I am trying to install Haskell framework on this server.<br><br>- Installation for GHC went ok. no error<br>- Installed ghc-7.4.1 from &quot;ghc-7.4.1-x86_64-unknown-linux.tar&quot;<br><br>then while trying to install (in configure step) Haskell platform version 2012.2.0.0.<br>
<br>I get following error:<br><br>[root@qa-engine1 haskell-platform-2012.2.0.0]# ./configure<br>**************************************************<br>*<br>*     Haskell Platform Source Installer<br>*<br>*     For the Haskell Platform 2012.2.0.0 and GHC 7.4.1<br>
*<br>**************************************************<br>checking build system type... x86_64-unknown-linux-gnu<br>checking host system type... x86_64-unknown-linux-gnu<br>checking target system type... x86_64-unknown-linux-gnu<br>
checking for ghc... /usr/local/lib/ghc-7.4.1/ghc<br>checking for ghc-pkg... /usr/local/lib/ghc-7.4.1/ghc-pkg<br>checking for hsc2hs... /usr/local/lib/ghc-7.4.1/hsc2hs<br>checking version of ghc... 7.4.1<br>checking version of ghc-pkg matches... yes<br>
checking ghc actually works... no<br>configure: error: Your installation of ghc does not appear to work.<br>  It cannot compile a simple program (see config.log for the details).<br>  If you installed ghc from a generic binary tarball then it is worth<br>
  checking that you have the &#39;gmp&#39; C library and header files installed.<br>  (On Debian-based systems this package is called libgmp3-dev.)<br>====================================<br><br>I have made sure that libc and gmp are indeed installed.<br>
<br>while trying use yum to make sure I have gmp installed.<br>====================================<br>[root@qa-engine1 haskell-platform-2012.2.0.0]# yum install gmp<br>Loaded plugins: fastestmirror<br>Loading mirror speeds from cached hostfile<br>
 * base: <a href="http://mirror.stanford.edu">mirror.stanford.edu</a><br> * extras: <a href="http://centos.mirror.facebook.net">centos.mirror.facebook.net</a><br> * updates: <a href="http://mirror.stanford.edu">mirror.stanford.edu</a><br>
Setting up Install Process<br>Package gmp-4.3.1-7.el6_2.2.x86_64 already installed and latest version<br>Nothing to do<br>========================================<br><br><br>Any help is appreciated.<br><br><br>Btw, I could make haskell latest version work on my mac osx.<br>
<br><br>-Manish<br>