<html><body>Hello,<br>Who is in charge of the ghc and haskell packages on Arch
 linux?&nbsp; The current system isn't working.<br><br>Arch linux tends to 
update packages very quickly.<br><br>For ghc, always having the latest ghc 
isn't a good thing.&nbsp; At least if you actually want to get some work 
done.&nbsp; A majority of the time the latest GHC is unusable. This is because
 the packages in hackage simply don't keep up.&nbsp; With the current ghc 
version(7.6.1) even some basic packages in hackage are not upgraded yet.&nbsp;
 <br><br>Right now, a large number of other haskell related packages are in 
the 
arch repos. Other than gtk2hs, I think these packages are pointless 
duplications.&nbsp; In the other cases, it has been my experience that it is 
simpler to maintain these packages through cabal rather than through 
pacman.&nbsp; Support for these packages in Arch should probably be 
dropped.<br><br>If you want to get work done in Arch with haskell, you should 
only install ghc and cabal-install(right now, you'll have to search the 
Internet for the old binaries, because the arch repos usually don't keep the 
old versions around).&nbsp; Then you should add these packages to "IgnorePkg 
=" in pacman.conf&nbsp; this way things won't break every couple of 
months.&nbsp; You can then choose to upgrade when you wish.<br><br>I hope that
 someone who is involved with the haskell Arch stuff reads this.&nbsp; The 
current model needs to be rethought.&nbsp; Linux should be sane by default, 
but I've lost many many hours learning that arch's relationship with haskell 
is not so :(&nbsp; Probably the best solution would be to make Arch 
automatically keep two versions of ghc around at any given time.<br><br>Thank 
you for your time,<br>Timothy Hobbs<br></body></html>