<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:dt="uuid:C2F41010-65B3-11d1-A29F-00AA00C14882" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta name="Microsoft Theme 2.00" content="Clear Day 011"><meta http-equiv=Content-Type content="text/html; charset=us-ascii"><meta name=Generator content="Microsoft Word 14 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri","sans-serif";}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body lang=EN-US link=blue vlink=purple><div class=WordSection1><p class=MsoNormal>I did a package check, and I always get a ton of these things:<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; Warning: haddock-html: E:\Plang\Haskell Platform\lib\extralibs\doc\haskell-src-1.0.1.4\html doesn't exist or isn't a directory<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal>Which I think is just missing documentation, so I ignore them. <o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal>But this time I also got this:<o:p></o:p></p><p class=MsoNormal>&nbsp; The following packages are broken, either because they have a problem listed above, or because they depend on a broken package.<o:p></o:p></p><p class=MsoNormal>&nbsp; HTTP-4000.2.3<o:p></o:p></p><p class=MsoNormal>&nbsp; haskell-platform-2012.2.0.0<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal>ghc-pkg list shows:<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; Cabal-1.10.1.0<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; Cabal-1.10.2.0<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; Cabal-1.14.0<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; Cabal-1.14.0<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; GLUT-2.1.2.1<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; GLUT-2.1.2.1<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; GLUT-2.1.2.1<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; {HTTP-4000.2.3}<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; HTTP-4000.2.5<o:p></o:p></p><p class=MsoNormal>&#8230;<o:p></o:p></p><p class=MsoNormal>&nbsp; {haskell-platform-2012.2.0.0}<o:p></o:p></p><p class=MsoNormal> haskell-platform-2012.4.0.0<o:p></o:p></p><p class=MsoNormal> haskell-src-1.0.1.4<o:p></o:p></p><p class=MsoNormal> haskell-src-1.0.1.4<o:p></o:p></p><p class=MsoNormal> haskell-src-1.0.1.5<o:p></o:p></p><p class=MsoNormal> haskell-src-1.0.1.5<o:p></o:p></p><p class=MsoNormal> (haskell2010-1.0.0.0)<o:p></o:p></p><p class=MsoNormal> (haskell2010-1.1.0.1)<o:p></o:p></p><p class=MsoNormal> (haskell2010-1.1.0.1)<o:p></o:p></p><p class=MsoNormal> haskell98-1.1.0.1<o:p></o:p></p><p class=MsoNormal> (haskell98-2.0.0.1)<o:p></o:p></p><p class=MsoNormal> (haskell98-2.0.0.1)<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal>Not sure what it all means, but looks somewhat goofy to me.<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal>I always just do &#8220;cabal installs&#8221;, and an occasional &#8220;&#8211;force-reinstalls&#8221; when told that it is the only option, but recently when they might fail tried a &#8220;cabal-dev install&#8221; a few times, I assume that is what the &#8220;{}&#8221; entries are, but am not sure if they can all peacefully coexist.<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal>Do I need to do a reset and start over? I hope not, as it took me many hours of fiddling to install some packages like glut, wxcore, and a few others.<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal>Argh.<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal><span style='font-size:10.0pt'>-------------------------------------------<br><br></span><o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p></div></body></html>