Hi,<br clear="all"><div>  I am having ghc 7.6.1 working here. But anytime I installed something with cabal-install, I got prompts like:</div><div><div><br></div><div>Warning: The following packages are likely to be broken by the reinstalls:</div>

<div>haskell98-2.0.0.2</div><div>ghc-7.6.1</div><div>Cabal-1.16.0</div><div>bin-package-db-0.0.0.0</div><div>directory-1.2.0.0</div><div>hpc-0.6.0.0</div><div>Continuing even though the plan contains dangerous reinstalls.</div>

</div><div><br></div><div>  And even worse, then I got:</div><div><div><br></div><div>&lt;command line&gt;: cannot satisfy -package Cabal-1.16.0: </div><div>    Cabal-1.16.0-dd0ce1db6fea670a788547ee85411486 is unusable due to missing or recursive dependencies:</div>

<div>      directory-1.2.0.0-8edf300597b0da609c8eccc9aa6d0cc3 process-1.1.0.2-03ae5757aa509ffbe497f42660cba52c unix-2.6.0.0-4bc27fc415f60036a88211de7cde3e9a</div><div>    (use -v for more information)</div></div><div><br>

</div><div>  What should I do? Why user space directory and process would interrupt Cabal in global space?</div>-- <br>竹密岂妨流水过<br>山高哪阻野云飞<br><br>And for G+, please use magiclouds#<a href="http://gmail.com" target="_blank">gmail.com</a>.<br>